ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Hokuyo laser not publishing any data

asked 2018-07-12 08:58:15 -0600

dkrivet gravatar image

I have a Jackal with a Hokuyo laser and I am wanting the hokuyo laser to publish information to /front/scan so that I am able to use the Nav stack with my jackal robot, but I am unsure how to do this. The hokuyo is properly connected to the jackal but is not publishing any data for some reason.

edit retag flag offensive close merge delete

Comments

1

Which hokuyo LiDAR are you using? It is connected via USB or ethernet? What node are you running to connect with the LiDAR?

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2018-07-12 09:47:34 -0600 )edit

I am using the Hokuyo UTM-30LX connected via USB. I am unsure of what node to use to connect to the LiDAR, that is the issue. Any help would be much appreciated, I am very new to ROS.

dkrivet gravatar image dkrivet  ( 2018-07-12 09:52:07 -0600 )edit

Ideally I want to publish the LiDAR data to a topic named /front/scan so I can use the nav stack to do autonomous navigation with the jackal

dkrivet gravatar image dkrivet  ( 2018-07-12 09:52:46 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-07-12 10:01:02 -0600

You need to install and run the URG node (URG is the protocol the hokuyo sensors use) which will connect to the hardware and publish the laser scan messages to the ROS system. You should be able to install this easily using apt-get.

By default this node publishes laser scan messages on the /scan topic, you can change this using a remap in your launch file to any topic name you want.

Hope this helps.

edit flag offensive delete link more

Comments

Thank you for the help. I have done this and got the laser to publish data correctly, however it is not publishing to my desired frame. I have actually used the hokuyo_node as the jackal is running ROS indigo and I think the hokuyo_node adds messages to the "laser" frame by default

dkrivet gravatar image dkrivet  ( 2018-07-13 05:35:54 -0600 )edit

However, I want to publish the the "front_laser" frame. How would I go about doing this? Thank you very much

dkrivet gravatar image dkrivet  ( 2018-07-13 05:36:16 -0600 )edit

You can use the parameter frame_id to set the frame laser scans are published in. The documentation isn't that clear on this unfortunately.

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2018-07-13 13:01:16 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-07-12 08:58:15 -0600

Seen: 713 times

Last updated: Jul 12 '18