Ask Your Question
1

Moveit gdb debugging

asked 2018-06-15 16:58:59 -0500

kolya_rage gravatar image

updated 2018-07-12 11:39:41 -0500

marguedas gravatar image

Hi, I'm trying to run move_group code through gdb. I compiled moveit from sources with --cmake-args -DCMAKE_BUILD_TYPE=Debug. Still, it seems like debug information haven't been lost. What I did: I ran my own node that uses move_group.plan(my_plan) and tried to step through plan(). But it doesn't step into the function like it hadn't written debugging data. I use ros kinetic Would use any help. Thanks

edit retag flag offensive close merge delete

Comments

Are you sure you're using ROS2? Is there MoveIt available for ROS2 already? It's just to make sure. I am working with ROS1 and I'm not sure if there is a bit difference when it comes to debugging.

AdamSorrel gravatar imageAdamSorrel ( 2018-07-07 06:10:54 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-25 08:40:35 -0500

v4hn gravatar image

I guess in your case move_group is actually a moveit::planning_interface::MoveGroupInterface. This class is only a ROS-wrapper which sends a goal to a ROS action.

If you want to debug the planning process you have to run the move_group node in gdb and set a breakpoint on the function that receives the action goal.

edit flag offensive delete link more
1

answered 2018-07-07 06:07:15 -0500

AdamSorrel gravatar image

Unfortunately I don't have a solution, but I'm dealing with the same issue. It is really confusing and there seems to be no documentation concerning this. Did you manage to resolve this?

Perhaps if we brainstorm what we tried, we will be able to move forward.

  1. Did you enable debugging in your launch file? If you're launching a whole move group, you can find this option in the move_group.launch on the top.

  2. This above step requires a gdb_settings.gdb file. This is referring to this type of input apparently.

  3. In my case I have (not sure how) managed to activate a process gdb -x gdb_settings.gdb ... move_group... to which I can attach using gdb attach <process id>. However trying to explore with info functions doesn't show any functions relevant to ROS or MoveIt! or anything such.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2018-06-15 16:58:59 -0500

Seen: 213 times

Last updated: Jul 25 '18