ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

No debugging symbols found in base_local_planner library

asked 2011-10-10 16:01:06 -0500

SimonC gravatar image

updated 2014-01-28 17:10:33 -0500

ngrennan gravatar image

Hey everyone,

I'm new to ROS. At the moment I'm using Eclipse CDT to debug the move_base node, more specifically the default local planner (base_local_planner/TrajectoryPlannerROS). When I start the move_base node, Eclipse can apparently find the debugging symbols for all the necessary packages (navfn, costmap_2d, etc) except for base_local_planner ( Indeed when I run the command "file" inside gdb, it tells me there's no debug symbol for that library.

I've tried to make sure the "-g" option was actually used to link the library, but I admit I got lost in the cmake files.

However I don't remember changing any linking option anywhere... anyone's got a clue to what may cause the problem? (and are the debugging symbols for this library present in your setup?)

Thanks, Simon C

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2011-10-10 19:31:32 -0500

tfoote gravatar image

The base_local_planner has the build type set to "Release" in the CMakeLists.txt which does not include debug symbols. Change it to RelWithDebug and recompile to get debugging symbols. Usually the release type should be commented out in released code to allow the system builder to change the build type for the whole system. You might want to open a ticket about this for the base_local_planner package.

edit flag offensive delete link more


Thanks that was it! Not sure why I didn't spot the option...!
SimonC gravatar image SimonC  ( 2011-10-11 01:20:04 -0500 )edit

Question Tools


Asked: 2011-10-10 16:01:06 -0500

Seen: 960 times

Last updated: Oct 10 '11