unable to launch turtlebot 3 on ROS kinetic

asked 2018-06-09 18:53:03 -0500

Kevinlin980 gravatar image

updated 2018-06-10 00:15:32 -0500

jayess gravatar image

Hi, i try to launch turtle bot 3 in ROS kinetic but i got the fellowing errors:

[ERROR]  [1528588143.963010]:  Tried to publish before configured, topic id 125
[ERROR]  [1528588144.021378]:  Creation of publisher failed: Checksum does not match: d537ed7b8d95065b6c83830430b93911,7250c1dc0b61c4190e78f528f599285f

i have tried updating turtlebot 3 msg folders and the OPENCR board version as described here: http://ros-users.122217.n3.nabble.com...

edit retag flag offensive close merge delete

Comments

Can you please update your question with the description and errors that you linked to so that the question is self-contained?

jayess gravatar image jayess  ( 2018-06-09 20:51:55 -0500 )edit

Here are the error i seen: [ERROR] Tried to publish before configured, topic id 125 [ERROR] Creation of publisher failed: Checksum does not match: i tried to rebuild the build and devel folder in catkin and update board version but it doesn't work still

Kevinlin980 gravatar image Kevinlin980  ( 2018-06-09 21:33:57 -0500 )edit

Can you please update your question with exactly what you've done to update the turtle 3 msg folders? That link has many entries and it's difficult know exactly what's lead you to this issue.

jayess gravatar image jayess  ( 2018-06-10 00:19:23 -0500 )edit

The second 'checksum' seems to be actually be an MD5 (here) of the turtlebot3_msgs/SensorState msg. The error ..

gvdhoorn gravatar image gvdhoorn  ( 2018-06-10 05:09:13 -0500 )edit

.. message you show could indicate the turtlebot 3 is publishing msgs of a different version than your ROS Kinetic installation. Are you sure everything is using the same version?

gvdhoorn gravatar image gvdhoorn  ( 2018-06-10 05:09:51 -0500 )edit

thank you for the comment, i have ros version 1.12.13 and i just updated catkin_ws/src and OPEN CR version to 1.0.15 following the tutorial: https://discourse.ros.org/t/turtlebot...

i still have the following error:

Kevinlin980 gravatar image Kevinlin980  ( 2018-06-10 12:44:11 -0500 )edit

Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

Kevinlin980 gravatar image Kevinlin980  ( 2018-06-10 12:44:15 -0500 )edit

My board manager is showing multiple releases of openCR since 1.0.15, the most current being 1.2.0. There has also been a release of version 1.0 of the turtlebot3 package recently. Have you tried using those 2 together

nickw gravatar image nickw  ( 2018-06-10 23:51:06 -0500 )edit