Remote machine topic listed, but no data transmitted

asked 2018-05-25 02:19:29 -0500

Huibuh gravatar image

updated 2018-05-25 02:43:04 -0500

Dear all, I ran into a problem which I don't know how to solve. I have a ROS server and a ROS client machine. Both are connected via network. I have confirmed the bi-directional connectivity according to http://wiki.ros.org/ROS/NetworkSetup#... :

  • Both machines can ping each other and themselves by hostname
  • Messages can be sent across the network using netcat in both directions

When the server is running roscore and a couple of nodes, I can see the topics of the server on the client (rostopic list). I can also subscribe to topics and see data being transmitted (rostopic echo /mytopic).

Now here is the strange problem: There is one topic which gets listed by "rostopic list" on the client, but no data is being received (rostopic echo /rtabmap/mapData). If I run the same command on the server, I can see the data coming in. I have no idea what's going on there. Could this be a rtabmap specific problem, or is this a ROS networking problem? Any ideas how to resolve this are appreciated.

Thanks

Specs:

  • ROS Kinetic on both machines
  • Both machines running Ubuntu 16.04
  • Latest rtabmap deb-packages installed on both machines
edit retag flag offensive close merge delete

Comments

Could you please verify whether the problem persists if you set ROS_IP on all involved hosts? I know you state that you have DNS working, but this is just to check whether it's a name resolution issue.

gvdhoorn gravatar imagegvdhoorn ( 2018-05-25 02:25:26 -0500 )edit

Thanks gdvhoorn. The hostnames resolve due entries in /etc/hosts on both machines. I have not tried setting ROS_IP. I will do so as soon as I get access to the machines and report back here.

Huibuh gravatar imageHuibuh ( 2018-05-25 02:42:08 -0500 )edit