ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

roswtf static check error: "Local network configuration is invalid"

asked 2018-05-17 04:14:54 -0500

130s gravatar image

updated 2018-05-19 10:13:11 -0500

roswtf complains, but ping resolves by passing hostname that roswtf failed checking. While it's possible that my computer's network is not configured in a normal way (although I don't remember I had to do anything unusual), is there a chance roswtf doing anything wrong?

term-1$ roscore

term-2$ roswtf
Loaded plugin tf.tfwtf
No package or stack in context
Static checks summary:

Found 1 error(s).

ERROR Local network configuration is invalid: Local hostname [myhostname] resolves to [xxxx:204:mmmm:2f40:nnnn:13ab:a569:9968%2,xxxx:204:mmmm:2f40:fdca:ff2e:8f90:7f28%3,fe80::7ad:7736:630f:7461%enp0s31f6,fe80::5b54:45f3:d998:14b9%wlp4s0,xxxx:204:mmmm:2f40:ee5:e220:744e:2329%2,fe80::42:7ff:fedd:872e%docker0], which does not appear to be a local IP address ['', '', '', ''].

$ ping myhostname
PING myhostname ( 56(84) bytes of data.
64 bytes from 130s-p50 ( icmp_seq=1 ttl=64 time=0.040 ms
64 bytes from 130s-p50 ( icmp_seq=2 ttl=64 time=0.035 ms

$ ifconfig
docker0   Link encap:Ethernet  HWaddr 02:42:07:dd:87:2e  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::42:7ff:fedd:872e/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:150800 errors:0 dropped:0 overruns:0 frame:0
          TX packets:254540 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:9119181 (9.1 MB)  TX bytes:384850257 (384.8 MB)

enp0s31f6 Link encap:Ethernet  HWaddr c8:5b:76:6a:61:39  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::7ad:7736:630f:7461/64 Scope:Link
          inet6 addr: xxxx:204:mmmm:2f40:nnnn:13ab:a569:9968/64 Scope:Global
          inet6 addr: xxxx:204:mmmm:2f40:ee5:e220:744e:2329/64 Scope:Global

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1597169 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1597169 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:160806226 (160.8 MB)  TX bytes:160806226 (160.8 MB)

wlp4s0    Link encap:Ethernet  HWaddr e4:a4:71:e5:e9:2b  
          inet addr:  Bcast:  Mask:
          inet6 addr: xxxx:204:mmmm:2f40:fdca:ff2e:8f90:7f28/64 Scope:Global
          inet6 addr: fe80::5b54:45f3:d998:14b9/64 Scope:Link

$ rospack find roswtf
$ rosversion roswtf
$ apt-cache policy ros-kinetic-roswtf
  Installed: 1.12.13-0xenial-20180222-233556-0800
  Candidate: 1.12.13-0xenial-20180222-233556-0800
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-05-17 07:43:53 -0500

gvdhoorn gravatar image

Your network / host has IPv6 enabled, which is not properly supported (last time I checked) by roswtf (and some other ROS tools). The resolver that roswtf (Python) uses returns the IPv6 addresses first, so roswtf doesn't see the IPv4 addresses. It then complains.

edit flag offensive delete link more


Confirmed that turning off ipv6 allows roswtf to not return error. But why does it return error with ipv6 on? Asked if that's what roswtf is supposed to do.

130s gravatar image 130s  ( 2018-05-19 10:22:51 -0500 )edit

I am getting the same error. Trying to determine if this might be causing an issue with transform timeout error. Does anyone know what problems this error might cause?

nsdolic gravatar image nsdolic  ( 2019-03-06 20:38:26 -0500 )edit

Question Tools

1 follower


Asked: 2018-05-17 04:14:54 -0500

Seen: 1,084 times

Last updated: May 19 '18