Ask Your Question
0

Unable to run moveit because of assimp packages

asked 2018-05-16 09:07:39 -0500

ysl208 gravatar image

updated 2018-05-16 09:28:56 -0500

When I try to run roslaunch baxter_moveit_config demo_baxter.launch, I get the error

/opt/ros/indigo/lib/rviz/rviz: symbol lookup error: /opt/ros/indigo/lib/libgeometric_shapes.so: undefined symbol: _ZN6Assimp8Importer18SetPropertyIntegerEPKciPb

and it crashes. These are my assimp packages:

$ apt list --installed | grep assimp
assimp-utils/trusty,now 3.0~dfsg-2 amd64 [installed,upgradable to: 3.2~dfsg-3~urp8+1]
libassimp-dev/trusty,now 3.2~dfsg-3~urp8+1 amd64 [installed]
libassimp-doc/trusty,now 3.0~dfsg-2 all [installed,upgradable to: 3.2~dfsg-3~urp8+1]
libassimp3/trusty,now 3.2~dfsg-3~urp8+1 amd64 [installed,automatic]
python-pyassimp/trusty,now 3.2~dfsg-3~urp8+1 all [installed]

I tried to solve it according to a previous thread but the mentioned solution did not work.

Any help? I feel like I have tried everything that I could but keep going in circles...

EDIT: This is what I did previously:

My assimp libraries were too high, so i reverted them to 3.0 manually (I downloaded the .deb file from launchpad and installed them using dbpk)

$ apt list --installed | grep assimp
assimp-utils/trusty,now 3.0~dfsg-2 amd64 [installed,upgradable to: 3.2~dfsg-3~urp8+1]
libassimp-dev/trusty,now 3.0~dfsg-2 amd64 [installed,upgradable to: 3.2~dfsg-3~urp8+1]
libassimp-doc/trusty,now 3.0~dfsg-2 all [installed,upgradable to: 3.2~dfsg-3~urp8+1]
libassimp3/trusty,now 3.0~dfsg-2 i386 [installed,upgradable to: 3.2~dfsg-3~urp8+1]
python-pyassimp/trusty,now 3.0~dfsg-2 all [installed,upgradable to: 3.2~dfsg-3~urp8+1]

However, once that was done, I would get this error message when starting rviz:

/opt/ros/indigo/lib/rviz/rviz: error while loading shared libraries: libassimp.so.3: wrong ELF class: ELFCLASS32

since this didnt work, I did a sudo apt-get -f install again and ended up with the 3.2 assimp versions as mentioned above.

edit retag flag offensive close merge delete

Comments

libassimp.so.3: wrong ELF class: ELFCLASS32

and:

libassimp3/trusty,now 3.0~dfsg-2 i386

you have the 32bit pkg on a 64bit system. That is not going to work.

gvdhoorn gravatar imagegvdhoorn ( 2018-05-16 09:16:16 -0500 )edit

this was my previous error message. so should i manually revert the packages again to version 3.0?

ysl208 gravatar imageysl208 ( 2018-05-16 09:23:13 -0500 )edit

I don't understand what you're trying to say.

gvdhoorn gravatar imagegvdhoorn ( 2018-05-16 09:23:52 -0500 )edit

my current version is libassimp3/trusty,now 3.2~dfsg-3~urp8+1 amd64 [installed,automatic], what should i do?

ysl208 gravatar imageysl208 ( 2018-05-16 09:26:58 -0500 )edit

I edited my post so that it is a bit more clear. Sorry for the confusion

ysl208 gravatar imageysl208 ( 2018-05-16 09:29:23 -0500 )edit

Why did you delete the question? That makes little sense to me.

gvdhoorn gravatar imagegvdhoorn ( 2018-05-17 02:19:13 -0500 )edit

I didnt delete the question? it's still there, i marked your answer as correct

ysl208 gravatar imageysl208 ( 2018-05-17 06:33:29 -0500 )edit

The question had the 'deleted' status when I looked at it. I undeleted it. Not sure what happened then. But it's also not important.

gvdhoorn gravatar imagegvdhoorn ( 2018-05-17 07:54:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-16 09:35:20 -0500

gvdhoorn gravatar image

The error msg was clear: you cannot use a 32bit library on a 64bit system like that. You could try reverting to the same versions again, but this time install only 64bit packages and see if that works.

No guarantees though.

edit flag offensive delete link more

Comments

it worked! thanks!

ysl208 gravatar imageysl208 ( 2018-05-16 11:56:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-16 09:07:39 -0500

Seen: 124 times

Last updated: May 16 '18