‘create’ is not a member of ‘cv::Tracker’ - ros_object_analytics

asked 2018-05-02 00:58:41 -0600

AlexChris003 gravatar image

I wanted to use the IntelROSProject and followed the installation guides. But when running catkin_make, an error occurs that I could not solve.

/home/aha/catkin_ws/src/ros_object_analytics-0.3.0/object_analytics_nodelet/src/tracker/tracking.cpp: In member function ‘void object_analytics_nodelet::tracker::Tracking::rectifyTracker(const cv::Mat&, const Rect2d&)’:
/home/aha/catkin_ws/src/ros_object_analytics-0.3.0/object_analytics_nodelet/src/tracker/tracking.cpp:48:14: error: ‘create’ is not a member of ‘cv::Tracker’
   tracker_ = cv::Tracker::create("MIL");
              ^
ros_object_analytics-0.3.0/object_analytics_nodelet/CMakeFiles/object_analytics_nodelet.dir/build.make:374: die Regel für Ziel „ros_object_analytics-0.3.0/object_analytics_nodelet/CMakeFiles/object_analytics_nodelet.dir/src/tracker/tracking.cpp.o“ scheiterte
make[2]: *** [ros_object_analytics-0.3.0/object_analytics_nodelet/CMakeFiles/object_analytics_nodelet.dir/src/tracker/tracking.cpp.o] Fehler 1
make[2]: *** Auf noch nicht beendete Prozesse wird gewartet …
CMakeFiles/Makefile2:5613: die Regel für Ziel „ros_object_analytics-0.3.0/object_analytics_nodelet/CMakeFiles/object_analytics_nodelet.dir/all“ scheiterte
make[1]: *** [ros_object_analytics-0.3.0/object_analytics_nodelet/CMakeFiles/object_analytics_nodelet.dir/all] Fehler 2
Makefile:127: die Regel für Ziel „all“ scheiterte
make: *** [all] Fehler 2
Invoking "make -j4 -l4" failed

Searching the web brought me to this question from stackoverflow. So I thought that the code from Intel needed an adjustment and opened an issue at the github site for the concerning package. But the only answer I got was the following:

your log error shows in your build environment, the version number was read as OpenCV 3.2 while the libraries actually found is NOT (probably 3.3.1 since you mentioned from Kinetic).

You may try avoid seeking for OpenCV 3.2 from your catkin workspace, by properly setup the environment.

At this time I had a separate OpencCV installation (3.2) that I tried to uninstall ro resolve the issue with no avail. In the end, I reinstalled my machine from ground up with Ubuntu (16.04 LTS) and all I needed (ROS kinetic and the NCSDK), but I still get the same error. And running pkg-config --modversion opencv outputs 2.4.9.1 as version which confueses me. Because right now I don't have a separate installation of OpenCV in any kind, only opencv(3) that comes packed with the full desktop install.

Can someone help me?

edit retag flag offensive close merge delete

Comments

pkg-config --modversion opencv results in 2.4.9.1 for me as well, but that seems to be the version of opencv-data or opencv-doc, which are not what you're after. You'd need ros-kinetic-opencv3, for which e.g. apt-cache policy ros-kinetic-opencv3 returns Installed: 3.3.1-5xenial-(...)

aPonza gravatar imageaPonza ( 2019-02-11 08:17:22 -0600 )edit

Actually nevermind, I see you solved the issue on github anyways.

aPonza gravatar imageaPonza ( 2019-02-11 08:17:48 -0600 )edit