Ask Your Question
0

Build package with system_lib not found

asked 2018-04-18 02:29:19 -0600

TifferPelode gravatar image

Hello everyone,

 I run catkin_make to build my package with this Warning:



-- +++ processing catkin package: 'katrina_gui'
-- ==> add_subdirectory(katrina_gui)
-- Boost version: 1.58.0
-- Found the following Boost libraries:
--   system
-- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy
CMake Warning at /opt/ros/kinetic/share/catkin/cmake/catkin_package.cmake:166 (message):
  catkin_package() DEPENDS on 'system_lib' but neither
  'system_lib_INCLUDE_DIRS' nor 'system_lib_LIBRARIES' is defined.
Call Stack (most recent call first):
  /opt/ros/kinetic/share/catkin/cmake/catkin_package.cmake:102 (_catkin_package)
  katrina_gui/CMakeLists.txt:22 (catkin_package)

My Environment Is:

Ubuntu 16.04 
ROS-Kinetic

I run this package under ROS-Indigo before, how can i fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-18 02:39:29 -0600

gvdhoorn gravatar image

system_lib is the name used as an example in the template CMakeLists.txt that catkin_create_pkg generates for you.

It is not intended to be an actual package.

Unless you happen to have a system dependency actually called system_lib, I recommend you remove it from your catkin_package(.. DEPENDS ..) list.

I run this package under ROS-Indigo before

I can't be sure, but I'm going to assume that would be impossible. Both Indigo and Kinetic use the same versions of Catkin, so I'd expect the same error to be shown to you.

edit flag offensive delete link more

Comments

Thanks, I'll try it later

TifferPelode gravatar imageTifferPelode ( 2018-04-18 10:17:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-18 02:29:19 -0600

Seen: 2,026 times

Last updated: Apr 18 '18