Global plan does not update in move_base

asked 2018-04-11 23:43:54 -0500

Sumit gravatar image

updated 2018-04-12 10:06:57 -0500

Environment:

OS: ubuntu 16.04 (Xenial) on an x64

ROS: kinetic

Navigation stack: 1.14.3

Config:

base_global_planner: "navfn/NavfnROS"

base_local_planner: "base_local_planner/TrajectoryPlannerROS"

planner_frequency: 10

Problem:

I have setup move_base as per the tutorial, however, Global Plan does not seem to update at a specified planner_frequency. It updates when the local_base_planner's path touches an obstacle, however, I want global plan to be recomputed with each new robot position. One way I seek to do this is to update the global plan at some frequency. Navigation tutorials mention that planner_frequency is new to Navigation stack 1.6.0. How do I update my Navigation stack with Kinetic ROS distribution? Also, if there is a better solution to my problem? Some easy way to constantly update global path as robot moves with my existing setup.

Than you.

edit retag flag offensive close merge delete

Comments

Which tutorial are you following? Because there is no nav_stack 1.16 and planner_frequency has been a component for a long time.

David Lu gravatar imageDavid Lu ( 2018-04-12 09:49:32 -0500 )edit

Sorry, my bad. I meant navigation 1.6.0 . I followed this for the setup: http://wiki.ros.org/navigation/Tutori...http://wiki.ros.org/move_base

I added planner_frequency: 10 in my config file, and I can see move_base/planner_frequency on my ros param server.

Sumit gravatar imageSumit ( 2018-04-12 10:05:56 -0500 )edit

I did sudo apt-get install ros-kinetic-navigation to install the navigation stack. And, package.xml file in kinetic/share/navigation shows version as "1.14.3"

Sumit gravatar imageSumit ( 2018-04-12 10:16:32 -0500 )edit
1

One annoying thing about the version numbers is that there should be a leading zero for navigation 1.06.0. So the version you have should definitely suffice.

10 hz if fairly fast. Can you set it to 0.5 to start and see if that works first?

David Lu gravatar imageDavid Lu ( 2018-04-12 17:14:22 -0500 )edit

Reducing "planner_frequency" to 0.5 or 1 seems to work. Thank you so much!

Sumit gravatar imageSumit ( 2018-04-13 15:46:19 -0500 )edit