Vehicle not moving, but robot_localization shows motion [closed]

asked 2018-04-02 02:03:11 -0600

KenYN gravatar image

I am trying to set up an Extended Kalman Filter, but I probably have some form of simple error. With a single Twist and a single Odometry input, the output Odometry shows the vehicle moving even when stationary, then steadily accelerating as the vehicle begins to move; it is like there is some hidden velocity component in my model.

My twist0 Twist data starts at all zeros (including covariance, although I have valid values in the ekf_template.yaml file), in the frame_id dr, which is my vehicle zero point on start-up relative to the map, which RViz says is (-24762, -53804) - I've set two_d_mode. My odom0 data starts with a pose position of (-24762, -53804) and a twist of all zeros, with frame_id map and child_frame_id dr.

The vehicle is not moving, but I see the odometry/filtered topic moving forward, and with both the yellow and purple areas growing as it moves. The topic has a pose growing away from zero, and a linear x twist of 2.6. frame_id is dr and child_frame_id of base_link.

I'm sure I've got something obvious wrong; this is part of a larger system so I have turned off the publish_tf option.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Tom Moore
close date 2022-01-25 04:45:33.101386


Have you checked that you are properly subscribed to the odometry topic in your visualizer? Also check that the origin frame from which the odometry is computed is the correct one.

thepirate16 gravatar image thepirate16  ( 2018-04-02 06:10:48 -0600 )edit

I believe I am correctly subscribed. For the time being, however, I have shelved this problem,.

KenYN gravatar image KenYN  ( 2018-04-09 00:45:55 -0600 )edit

Please provide (a) your full EKF config and (b) a sample sensor message for every sensor input. This sounds like you are only feeding some subset of the velocity variables to the EKF.

Tom Moore gravatar image Tom Moore  ( 2018-04-13 06:13:21 -0600 )edit