Ask Your Question
1

freenect_launch vs openni_launch recommendations for kinect

asked 2018-03-28 02:27:58 -0500

Jean_jierrre gravatar image

updated 2018-04-03 17:15:23 -0500

Hi everyone,

I'm struggling with those nodes for connecting to my kinect. The thing is, I tried several ways to have the most stable data transmission between rgb and depth sensors through ros without sucess. I mean, I got good results when I mapped a close indoor room, but always getting some kind of error for openni and freenect I never understood and which sometimes get solved by restarting my laptop. For example, when I was using freenect_launch everything seemed work fine most of time, but I noticed every time I used that group of nodes, more common I got camera/camera_nodelet_manager errors, or such as [camera/driver-2] escalating to SIGTERM | [camera/camera_nodelet_manager] escalating to SIGTERM or a Sorry, the application nodelet has stopped unexpectedly (which turns out on a log file error at startup every time I turn on my laptop, fortunately I managed to erase those logging errors). Or the kinect device is not connected and turns out that I have to restart the laptop in order it recognizes kinect. I don't know what could be wrong with freenect_launch or if it's on my kinect or something I missed, but everything should work fine.

  • I'm using kinect V1 model 1414, under ros-kinetic and obviously freenect-camera and openni-camera.
  • on port USB 2.0 cause I know it has some tricky behavior with transfer rates.
  • And supplied by the following ros document kinect supply

I'm working with depth sensor so I'm also using depthimage-to-laserscan package, with the following parameters I think should be fine:

          <!-- depth image to laser scan -->

<node pkg="depthimage_to_laserscan" type="depthimage_to_laserscan" name="depthimage_to_laserscan">

  <param name="scan_height" value="1"/>  
  <param name="output_frame_id" value="/$(arg camera)_depth_frame"/>
  <param name="range_min" value="0.45"/> 
  <!-- <param name="range_max" value="5.0"/> -->
  <param name="scan_time" value="0.1"/> 
  <remap from="image" to="$(arg camera)/$(arg depth)/image_raw"/>
  <remap from="scan" to="$(arg scan_topic)"/>

  <remap from="$(arg camera)/image" to="$(arg camera)/$(arg depth)/image_raw"/>
  <remap from="$(arg camera)/scan" to="$(arg scan_topic)"/>

</node>

Another common error I got like these. By the way everytime I started freenect_launch this message appeared at the end Stopping device RGB and Depth stream flush (after the typical calibrations warns, the ones that tell you haven't calibrate your camera), what does that mean? is it irrelevant?

Because of that, I started using openni_launch and I had the same issues that freenect_launch, but rarely. At first I started using that without OpenNi unstable nor SensorKinect, cause I didn't noticed that at the end from openni_camera documentation it was needed to have the kinect working properly. So I followed the steps from here and here which are practically the same, and managed installing those but unfortunately as a super user. I couldn't do that as a normal user cause it didn't let me.

After that, openni and freenect started getting worse and now I'm unable to launch correctly both of them. When I launch openni_launch I got this ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-03 16:10:07 -0500

Jean_jierrre gravatar image

updated 2018-04-03 23:10:04 -0500

I solved it partially by reinstalling ubuntu with dualboot again and making new supply circuit according to kinect powering. So I had a huge kinect compatibility and drivers interface problem after installing openni_camera. After that I noticed that like 5% of time, data transmission from kinect doesn't recognize Microsoft Corp. Xbox NUI Camera by typing lsusb on terminal repeatedly. I mean, it recognizes the three sources Microsoft Corp. Xbox NUI Camera, Microsoft Corp. Xbox NUI Audio and Microsoft Corp. Xbox NUI Motor, but not always the three of them, even after formating.

I think it's goona work fine most of time since now, but I want it to work properly and without concerning about how much time I have left before it starts behaving wrong and having every time more conflicts with camera/nodelet_camera.

Another symptom I've always had just after killing freenect_launch or openni_launch is this one from imgur. A crashing report that probably will make a new one pops up next time I restart ubuntu.

This time I haven't installed OpenNI, nor SensorKinect, and similar things related to interfacing with kinect. Just ROS, freenect_camera, launch and openni_camera and launch, and obviously another packages I'm working with like rosserial, navigation, nav2d, teleoptwistkeyboard, etc.

Sorry, I forgot to mention laptop and some specs:

-Asus Intel Core i7-7500U, up to GHz, 12 Gb RAM, HDD 1 Tb, Nvidia Geforce 940MX, OS as Free DOS and under UEFI.

-It has installed dualtboot with Windows 10 at first and ubuntu 16.04.4 LTS.

-ROS Kinetic version.

-Two kinects, model 1414 which are in perfect conditions supposedly.

-In order to installing ubuntu I had to use usb2.0 and enable security mode and change some starting parameters which I don't remember at this moment, but I guess that doesn't matter, right?

Is there any clue to resolve this problem?

Thanks

------------EDIT 1----------------

Hey guys, I noticed the usb 2.0 and 3.0 data transfer is veeeeery slow. I've got used to that, but that must be the problem! My laptop have an uefi mode, not like most of BIOS systems, so if I managed to set it correctly for a normal or better usb data transmission, maybe this problem is solved.

------------EDIT 2----------------

I managed to improve usb transmission data through windows, and ubuntu inside BIOS, but that wasn't the problem. it has to be nodelet the problem. After installing all libfreenect dependencies, seems there is no longer any problems with usb transmission and lsusb always shows up three kinect components.

The problem definitely resides on camera/camera_nodelet_manager. Most of times I kill freenect camera nodes it shows this error fucking nodelet.

I hope you can help me with that

edit flag offensive delete link more

Comments

I've definitely solved this issue by reinstalling ROS and updating the system. I also had to delete and manually installing freenect_camera and set my video card driver (cause I forgot set that since the system used the default X.Org.Server one). So it was solved like two weeks ago

Jean_jierrre gravatar imageJean_jierrre ( 2018-04-25 01:10:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-28 02:27:58 -0500

Seen: 352 times

Last updated: Apr 03 '18