ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Cannot initialise gstreamer pipeline

asked 2018-03-26 08:03:50 -0600

nina-lg gravatar image


[System Info:]

  • Ubuntu 16.04 in a Virtualbox
  • Kernel: Linux 4.13.0-36-generic
  • Architecture: x86-64
  • ROS kinetic

I am trying to follow the audio common installation and ran into the problem mentioned here i now installed

sudo apt-get install gstreamer1.0-alsa

And the pipeline seemed to work properly:

gst-launch-1.0 alsasrc ! audioconvert ! audioresample ! alsasink

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstAudioSrcClock
Redistribute latency...
Redistribute latency...
^Chandling interrupt.
Interrupt: Stopping pipeline ...
Execution ended after 0:00:12.309985956
Setting pipeline to PAUSED ...
Setting pipeline to READY ...

But I cant hear any sound from my mic... Anyone here, who has a hint how to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-03-27 03:26:53 -0600

nina-lg gravatar image

Solved it myself!

gst-launch-1.0 alsasrc ! alsasink sync=false

worked fine!

edit flag offensive delete link more


Is there any trade-off when setting syn=false? Is there a fundamental necessity to set sync=false in some cases? Or is this something that became necessary with the new gstreamer release?

gvdhoorn gravatar image gvdhoorn  ( 2018-03-27 05:31:32 -0600 )edit

And more importantly: should the tutorial you linked in #q286550 be updated?

gvdhoorn gravatar image gvdhoorn  ( 2018-03-27 05:32:27 -0600 )edit

Shouldn't there be an explaination on why it worked fine?

Rohan0993 gravatar image Rohan0993  ( 2018-12-24 04:02:49 -0600 )edit

fixed it for me as well

billy gravatar image billy  ( 2019-10-03 00:49:15 -0600 )edit

Question Tools

1 follower


Asked: 2018-03-26 08:03:50 -0600

Seen: 1,425 times

Last updated: Mar 27 '18