ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

kuka kr10r1100 sixx "floats" above ground_plane in Gazebo

asked 2018-03-13 15:14:20 -0500

ManMan88 gravatar image

I'm trying to simulate kuka kr10r1100 sixx in Gazebo - so far everything works great except that the robot spawns above the ground plane - i.e. it has an offset from the origin but only in the z axis (see the image below). Originally it would spawn and then slowly fall until hitting the ground. Then I set the base_link as fixed to the world frame (and also set it as static), so now it stays like that in the "air".

I'm using ROS kinetic on Ubuntu 16.04.4.

I took the kuka urdf file from the kuka_experimental repository I've checked that the STL files origin is where it supposed to be (by the way, the robot is located well in rviz (see below)). One more thing regarding rviz, it gives the following error for all the STL files:

The STL file 'package://kuka_kr10_support/meshes/kr10r1100sixx/visual/base.stl' is malformed. It starts with the word 'solid', indicating that it's an ASCII STL file, but it does not contain the word 'endsolid' so it is either a malformed ASCII STL file or it is actually a binary STL file. Trying to interpret it as a binary STL file instead.

I followed these two tutorials: tutorial1 tutorial2 to update the urdf file to work with Gazebo. I added the transmissions (I don't see how this can affect my problem), I added this:

    <plugin name="gazebo_ros_control" filename="">

and I added the gazebo colors (but the problem existed before the colors). I also added inertial properties to each link because without it Gazebo wouldn't accept the urdf file. Except these changes, I did not change anything.

Did someone encountered something similar and have some suggestions how to solve it?



image description


image description

edit retag flag offensive close merge delete


Not an answer, but just to make you aware of it: the kr10r1100sixx model is undergoing some maintenance. See ros-industrial/kuka_experimental#104.

gvdhoorn gravatar image gvdhoorn  ( 2018-03-14 03:45:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-03-18 12:06:34 -0500

gvdhoorn gravatar image

Could this be (another manifestation of) #q284241?

edit flag offensive delete link more


Yeah, the reason for the slow falling is the same bug. Thanks! Although it doesn't answer the spawning in high z -> which I just found out was my mistake! I mistakenly just spawned it there and did not notice :(

ManMan88 gravatar image ManMan88  ( 2018-03-21 14:38:37 -0500 )edit

What do you mean "mistakenly just spawned it there" ?
I have the same problem.

VincyXiao gravatar image VincyXiao  ( 2019-07-12 11:33:25 -0500 )edit

for example, look at the following command: rosrun gazebo_ros spawn_model -file rospack find MYROBOT_description/urdf/MYROBOT.urdf -urdf -x 0 -y 0 -z 1 -model MYROBOT. the -x -y -z options tells gazebo where to spawn the robot. In this case it would spawn in (x,y,z) = (0,0,1)

ManMan88 gravatar image ManMan88  ( 2019-07-13 05:47:12 -0500 )edit

Question Tools



Asked: 2018-03-13 15:14:20 -0500

Seen: 981 times

Last updated: Mar 13 '18