ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

roslaunch: [ ] is neither a launch file in package [ ] nor is [ ] a launch file name

asked 2018-03-13 11:35:26 -0500

Alexis gravatar image

updated 2018-03-13 11:42:50 -0500

gvdhoorn gravatar image

Hi everyone,

I know a lot of answers to this kind of problem are lurking around, but I swear everything I tried isn't working. I've sourced the environment multiple times manually, or adding source/home/alexis/catkin_ws/devel/setup.bash inside the ~./bashrc file. I am positive the folder and files do exist. I've also built it multiple times via catkin build or catkin_make.

But still, whenever I run the command:

roslaunch catkin_ws map_navigation_stage_psu.launch

the error that is in the title shows up. I honestly don't know what to do anymore.

The content of "map_navigation_stage_psu.launch" is as follow:

      <include file="$(find catkin_ws)/src/turtlebot/navigation/map_navigation/launch/turtlebot_stage_psu.launch"/>
     <node name="map_navigation" pkg="catkin_ws" type="map_navigation_node" output="screen">

Thank you for bearing with me

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2018-03-13 11:44:23 -0500

gvdhoorn gravatar image

updated 2018-03-13 11:45:38 -0500

But still, whenever I run the command:

roslaunch catkin_ws map_navigation_stage_psu.launch

catkin_ws is the name of the directory that contains your Catkin workspace. It is not a package.

roslaunch can only find (and $(find ..)) packages, not workspaces.

Try replacing catkin_ws with the actual package name and see if that works any better.


source/home/alexis/catkin_ws/devel/setup.bash inside the ~./bashrc file.

If this is not a typo, this line is missing a space between source and /home/alexis/...

edit flag offensive delete link more

answered 2018-03-18 02:38:05 -0500

Nitin gravatar image

updated 2018-03-18 02:40:34 -0500

It looks, you are trying to use catkin workspace name in place of package name. Catkin workspace and package both are different.

A catkin package is simply a directory descended from ROS_PACKAGE_PATH that has a package.xml file in it. Packages are the most atomic unit of build and the unit of release.

A catkin workspace is a folder where you modify, build, and install catkin packages. This workspace can contain many packages.

So modify include tag and node tag of the above launch file as per the actual package name.

Please find the modified content of map_navigation_stage_psu.launch file below.

     <include file="$(find map_navigation)/launch/turtlebot_stage_psu.launch"/>
     <node name="map_navigation" pkg="map_navigation" type="map_navigation_node" output="screen">

The command to launch map_navigation_stage_psu.launch is

roslaunch map_navigation map_navigation_stage_psu.launch

Note: I assumed that the package name is map_navigation. The package name can be verified using package.xml.

edit flag offensive delete link more


I modified the content as suggested, checked if there was another package with the same name and corrected the typo but still having the error. Though thank you all for correcting the mistakes that were made until now,, it really helps.

Alexis gravatar image Alexis  ( 2018-03-20 03:07:11 -0500 )edit

Please share the updated launch file content.

Nitin gravatar image Nitin  ( 2018-03-20 04:39:51 -0500 )edit

answered 2018-03-15 03:27:26 -0500

dpakshimpo gravatar image

I also faced a similar issue, try deleting and build and devel folder and doing catkin_make again and sourcing it. Is it possible that you have a package by the same name else where in the system under a different workspace?

edit flag offensive delete link more

Question Tools


Asked: 2018-03-13 11:35:26 -0500

Seen: 1,618 times

Last updated: Mar 18 '18