Segmentation Fault (rospack, rosrun, etc.) ROS Kinetic Ubuntu 16.04

asked 2018-03-12 09:59:50 -0500

updated 2018-03-13 10:01:41 -0500

Hi everyone,

I have just installed ROS Kinetic in a Ubuntu 16.04 machine but it seems that something is wrong because ROS does not work as normally.

If I do a roscd + <tab> I get no pkg recommendation and an error:

roscd *** Error in `rosstack': double free or corruption (out): 0x00007f7f0004aab0 ***
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x777e5)[0x7f7f000c37e5]
/lib/x86_64-linux-gnu/libc.so.6(+0x8037a)[0x7f7f000cc37a]
/lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c)[0x7f7f000d053c]
/opt/ros/kinetic/lib/librospack.so(_ZN7rospack8StackageD1Ev+0x44)[0x7f7f009cdee4]
/opt/ros/kinetic/lib/librospack.so(_ZN7rospack11Rosstackage11addStackageERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x3a4)[0x7f7f009c3e84]
/opt/ros/kinetic/lib/librospack.so(_ZN7rospack11Rosstackage11crawlDetailERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEbibRSt6vectorIPNS_20DirectoryCrawlRecordESaISB_EERN5boost9unordered13unordered_setIS6_NSF_4hashIS6_EESt8equal_toIS6_ESaIS6_EEE+0x53b)[0x7f7f009c5abb]
/opt/ros/kinetic/lib/librospack.so(_ZN7rospack11Rosstackage11crawlDetailERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEbibRSt6vectorIPNS_20DirectoryCrawlRecordESaISB_EERN5boost9unordered13unordered_setIS6_NSF_4hashIS6_EESt8equal_toIS6_ESaIS6_EEE+0x459)[0x7f7f009c59d9]
/opt/ros/kinetic/lib/librospack.so(_ZN7rospack11Rosstackage5crawlESt6vectorINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEESaIS7_EEb+0x166)[0x7f7f009c6966]
/opt/ros/kinetic/lib/librospack.so(_ZN7rospack11rospack_runEiPPcRNS_11RosstackageERNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0xfeb)[0x7f7f009d7d9b]
rosstack(main+0x54)[0x400b04]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7f7f0006c830]
rosstack(_start+0x29)[0x400bd9]
======= Memory map: ========

Later, I tested to launch, for instance, the rviz program but getting the next message:

find: ‘’: No such file or directory
[ INFO] [1520875186.477656721]: rviz version 1.12.15
[ INFO] [1520875186.477721911]: compiled against Qt version 5.5.1
[ INFO] [1520875186.477734832]: compiled against OGRE version 1.9.0 (Ghadamon)
Segmentation fault (core dumped)

If I do a "rospack profile" I get:

Segmentation fault (core dumped)

I have tried to re-install everything but no success.

Any help would be appreciated.

Regards,

Raúl

Edit 1:

I installed ROS Kinetic following the instructions in the wiki.

This is the brief information about me PC:

-Computer-
Processor       : 4x Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
Memory      : 16311MB (3431MB used)
Operating System        : Ubuntu 16.04.4 LTS
Date/Time       : lun 12 mar 2018 18:16:24 CET
-Display-
Resolution      : 3840x1080 pixels
OpenGL Renderer     : Unknown
X11 Vendor      : The X.Org Foundation
-Multimedia-
Audio Adapter       : HDA-Intel - HDA Intel PCH
-SCSI Disks-
ATA WDC WD10EURX-63C
hp DVD-RAM GH80N

Edit 2:

apt list --upgradable
Listing... Done

Edit 3:

python --version
Python 2.7.12
edit retag flag offensive close merge delete

Comments

Please tell us how you installed ROS, what platform this is, CPU architecture, versions of things, etc.

Also: please try and post error messages in English only. I understand what it says now, but English is the language used on this forum, so please stick to that.

gvdhoorn gravatar image gvdhoorn  ( 2018-03-12 11:39:56 -0500 )edit

Hi @gvdhoorn, thank you for your answer. I have edited the question with the information you asked.

raul.perula gravatar image raul.perula  ( 2018-03-12 12:15:06 -0500 )edit

the reason why rviz always crash is possible fatal bug in your code , could you please paste the your code ?

HRG-lsw gravatar image HRG-lsw  ( 2018-03-13 00:15:52 -0500 )edit

Hi @HRG-lsw, I have still no source code associated. My problem seems to be related to the installation because I cannot even do a rospack or a rosrun.

raul.perula gravatar image raul.perula  ( 2018-03-13 05:28:44 -0500 )edit

Any help? cc @ahendrix@tfoote

raul.perula gravatar image raul.perula  ( 2018-03-13 05:59:03 -0500 )edit

Something to check: is your entire system up-to-date? If you have partially updated some things, that may explain the SEGFAULTs. Can you do a sudo apt-get update and then apt list --upgradable and add the output to your original question?

gvdhoorn gravatar image gvdhoorn  ( 2018-03-13 06:21:30 -0500 )edit

I have add the result of the system checking @gvdhoorn . As you can see, everything ok about upgrades. There must be another problem.

raul.perula gravatar image raul.perula  ( 2018-03-13 07:20:49 -0500 )edit

Can you run the python binary by itself? What is the output of python --version? And after starting python, and then typing import rospkg, does that work?

gvdhoorn gravatar image gvdhoorn  ( 2018-03-13 07:47:12 -0500 )edit