Ask Your Question
0

nao.rviz config file not found in the repo.

asked 2018-03-01 12:35:43 -0600

ravit gravatar image

updated 2018-03-04 15:03:37 -0600

jayess gravatar image

Hello,

I'm following the tutorial on http://wiki.ros.org/nao/Tutorials/Get... and in the Step 1.1. where I'm supposed to select a nao.rviz

src/nao_robot/nao_description/config/nao.rviz

I cannot find in the specified directory and as a result not able to load nao onto rviz.

You quick response would be much appreciated. Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-03-04 12:41:42 -0600

marguedas gravatar image

This tutorial seems outdated as it starts with "Note: WARNING: This tutorial may be outdated and specific to the Nao ROS packages v0.1.". Maybe there is another tutorial that is more recent/up-to-date?

Looking at the nao_robot repository, there are 2 RViz config files:

  • urdf.rviz file in src/nao_robot/nao_description/config/urdf.rviz that displays the robot model and it's transforms
  • nao_full.rviz at nao_bringup/config/nao_full.rviz. It seems to display the sensor data as well and not only the model of the robot.

As the screenshot in the tutorial shows camera images and sonar data, I think you want to use the second one. Hope this helps,

edit flag offensive delete link more

Comments

Thanks for your reply. I already tried the config file you specified. As soon as I select this config file rviz crashes with this error:

ravit gravatar imageravit ( 2018-03-05 04:29:40 -0600 )edit

@ravit: your comment doesnt contain the error message. Your question doesnt give enough information. Please update your question with the set of commmands you ran as well as any meaningful information to help us help you. See support guidelines

marguedas gravatar imagemarguedas ( 2018-03-05 23:00:36 -0600 )edit

Thanks and sorry about that, I'm rather new to this forum.

When I select nao_full.rviz at nao_bringup/config/nao_full.rviz -- rviz crashes with the following message

ravit gravatar imageravit ( 2018-03-06 03:55:35 -0600 )edit

When I select urdf.rviz file in src/nao_robot/nao_description/config/urdf.rviz - rviz snapshot: https://www.dropbox.com/s/2bie6wse7ss... Under 'RobotModel'>>'Status Error">>'URDF' - Parameter [robot_description] does not exist, and was not found by searchParam()

ravit gravatar imageravit ( 2018-03-06 04:04:14 -0600 )edit

This still doesn't give use the commands you ran before starting RViz. Did you run any launchfile from nao_bringup before starting RViz (cf 1.0 of tutorial) ? robot description is set in nao_description/upload_nao.launch, that is launched automatically when you start nao_bringup/nao_full_py.launch

marguedas gravatar imagemarguedas ( 2018-03-09 11:44:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-01 12:35:43 -0600

Seen: 305 times

Last updated: Mar 04 '18