Server error while running "roscore".

asked 2018-02-27 00:18:06 -0600

updated 2018-02-27 03:06:26 -0600

when I run roscore this error occurs. version:-ROS Kinetic UBUNTU 16.04LTS

melvin@melvin-HP-Notebook:~$ roscore
... logging to /home/melvin/.ros/log/d1cb9254-1ab8-11e8-b6a6-441ca8984d6d/roslaunch-melvin-HP-Notebook-4976.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Unable to contact my own server at [http://192.168.43.40:39081/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

    ping 192.168.43.40

For more tips, please see

    http://www.ros.org/wiki/ROS/NetworkSetup

The traceback for the exception was written to the log file

export | grep -i ros gives output as

melvin@melvin-HP-Notebook:~$ ping 192.168.43.40
PING 192.168.43.40 (192.168.43.40) 56(84) bytes of data.
^Z
[1]+  Stopped                 ping 192.168.43.40
melvin@melvin-HP-Notebook:~$ export | grep -i ros
declare -x CMAKE_PREFIX_PATH="/opt/ros/kinetic"
declare -x LD_LIBRARY_PATH="/usr/local/cuda-8.0/lib64:/usr/local/lib:/opt/ros/kinetic/lib:/opt/ros/kinetic/lib/x86_64-linux-gnu"
declare -x OLDPWD="/home/melvin/ros"
declare -x PATH="/usr/local/cuda-8.0/bin:/opt/ros/kinetic/bin:/home/melvin/bin:/home/melvin/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin"
declare -x PKG_CONFIG_PATH="/opt/ros/kinetic/lib/pkgconfig:/opt/ros/kinetic/lib/x86_64-linux-gnu/pkgconfig"
declare -x PYTHONPATH="/opt/ros/kinetic/lib/python2.7/dist-packages"
declare -x ROSLISP_PACKAGE_DIRECTORIES=""
declare -x ROS_DISTRO="kinetic"
declare -x ROS_ETC_DIR="/opt/ros/kinetic/etc/ros"
declare -x ROS_IP="192.168.43.40"
declare -x ROS_MASTER_URI="http://localhost:11311"
declare -x ROS_PACKAGE_PATH="/opt/ros/kinetic/share"
declare -x ROS_ROOT="/opt/ros/kinetic/share/ros"
declare -x TURTLEBOT_GAZEBO_MAP_FILE="/opt/ros/kinetic/share/turtlebot_gazebo/maps/playground.yaml"
declare -x TURTLEBOT_GAZEBO_WORLD_FILE="/opt/ros/kinetic/share/turtlebot_gazebo/worlds/playground.world"
declare -x TURTLEBOT_MAP_FILE="/opt/ros/kinetic/share/turtlebot_navigation/maps/willow-2010-02-18-0.10.yaml"
melvin@melvin-HP-Notebook:~$
edit retag flag offensive close merge delete

Comments

So, did you check if you can ping 192.168.43.40? What is the result? Please also post the output of export | grep -i ros by editing your question?

mgruhler gravatar imagemgruhler ( 2018-02-27 01:43:01 -0600 )edit

The two error messages shown at the top of your screenshot (please don't post screenshots of text in the future) are suspicious. Did you add any export lines to your .bashrc? Those lines appear to be IPv6 addresses.

gvdhoorn gravatar imagegvdhoorn ( 2018-02-27 02:56:21 -0600 )edit

once i disabled my IPv6.but now i enabled again. and @mig i updated my question. cant ping.

sudo_melvinyesudas gravatar imagesudo_melvinyesudas ( 2018-02-27 03:03:41 -0600 )edit

So can you please show us those lines from your .bashrc? There seems to be an error or two in there.

gvdhoorn gravatar imagegvdhoorn ( 2018-02-27 03:05:05 -0600 )edit