Ask Your Question
0

working catkinized orb slam 2 or other monocular slam

asked 2018-02-10 10:01:38 -0600

Ben12345 gravatar image

updated 2018-02-11 01:22:01 -0600

gvdhoorn gravatar image

I’ve been trying to install orb slam 2 for a few days, following the instructions on the hit hub repo. The install always hangs at 59% I’ve tried the catkinised version from enth-asl on GitHub and I get an error rested to log that I don’t have any ideas on how to fix. https://github.com/ethz-asl/orb_slam_...

It really should not be this hard to install a package that is used so much. I’ve tried on both Ubuntu 14.04 and 16.04

Does anyone have any links to a working catkinzed package, or know of another monocular slam package that gives point cloud data? Preferably a Sufi apt-get install job, or a catkinized package.


Edit: This is the output from following Femer's instructions -

 catkin build orb_slam_2_ros
-------------------------------------------------
Profile:                     default
Extending:          [cached] /opt/ros/kinetic
Workspace:                   /home/ubuntu
-------------------------------------------------
Source Space:       [exists] /home/ubuntu/src
Log Space:          [exists] /home/ubuntu/logs
Build Space:        [exists] /home/ubuntu/build
Devel Space:        [exists] /home/ubuntu/devel
Install Space:      [unused] /home/ubuntu/install
DESTDIR:            [unused] None
-------------------------------------------------
Devel Space Layout:          linked
Install Space Layout:        None
-------------------------------------------------
Additional CMake Args:       None
Additional Make Args:        None
Additional catkin Make Args: None
Internal Make Job Server:    True
Cache Job Environments:      False
-------------------------------------------------
Whitelisted Packages:        None
Blacklisted Packages:        None
-------------------------------------------------
Workspace configuration appears valid.
-------------------------------------------------
[build] Found '2' packages in 0.0 seconds.                                                                                                    
[build] Package table is up to date.                                                                                                          
Starting  >>> orb_slam_2_catkin                                                                                                               
______________________________________________________________________________________________________________________________________________
Errors     << orb_slam_2_catkin:cmake /home/ubuntu/logs/orb_slam_2_catkin/build.cmake.007.log                                                 
CMake Error at /home/ubuntu/src/orb_slam_2_catkin/CMakeLists.txt:6 (find_package):
  By not providing "Findcatkin_simple.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "catkin_simple", but CMake did not find one.

  Could not find a package configuration file provided by "catkin_simple"
  with any of the following names:

    catkin_simpleConfig.cmake
    catkin_simple-config.cmake

  Add the installation prefix of "catkin_simple" to CMAKE_PREFIX_PATH or set
  "catkin_simple_DIR" to a directory containing one of the above files.  If
  "catkin_simple" provides a separate development package or SDK, be sure it
  has been installed.


cd /home/ubuntu/build/orb_slam_2_catkin; catkin build --get-env orb_slam_2_catkin | catkin env -si  /usr/bin/cmake /home/ubuntu/src/orb_slam_2_catkin --no-warn-unused-cli -DCATKIN_DEVEL_PREFIX=/home/ubuntu/devel/.private/orb_slam_2_catkin -DCMAKE_INSTALL_PREFIX=/home/ubuntu/install; cd -
..............................................................................................................................................
Failed     << orb_slam_2_catkin:cmake          [ Exited with code 1 ]                                                                         
Failed    <<< orb_slam_2_catkin                [ 0.3 seconds ]                                                                                
Abandoned <<< orb_slam_2_ros                   [ Unrelated job failed ]                                                                       
[build] Summary: 0 of 2 packages succeeded.                                                                                                   
[build]   Ignored:   None.                                                                                                                    
[build]   Warnings:  None.                                                                                                                    
[build]   Abandoned: 1 packages were abandoned.                                                                                               
[build]   Failed:    1 packages failed.                                                                                                       
[build] Runtime: 0.4 seconds total.

The relevant package is in the src folder. Also started from scratch and cloned orb slam gits and the catkin simple git but got the same output.

I'm not a linux guru, and appreciate that this is probably very obvious to someone that works with ROS day in, day out, but the documentation in this case is extremely poor.

Catkin make also failed before, but for a different reason. It took an hour to get to that point and i accidentally deleted the ... (more)

edit retag flag offensive close merge delete

Comments

1

Hi, can you please copy and paste the error that you get?

Femer gravatar imageFemer ( 2018-02-10 10:37:03 -0600 )edit

I can't copy the output because the system completely hangs wen installing using the instructions on the ORB_SLAM2 github - https://github.com/raulmur/ORB_SLAM2 But te final output is something along the lines of [59%] building cxx object cmakefiles/ORB_SLAM2.dir/src/Viewer.cc.o

Ben12345 gravatar imageBen12345 ( 2018-02-10 11:16:54 -0600 )edit

Please don't use an answer to provide an update to your question. You can edit your question with this information. This isn't a forum.

jayess gravatar imagejayess ( 2018-02-10 22:36:30 -0600 )edit

re: cannot find package error: that error is quite common (and a google search should have turned up quite some results). It's caused by the fact that you most likely didn't install all the dependencies of the pkg before trying to build it.

See #q252478 for the general procedure.

gvdhoorn gravatar imagegvdhoorn ( 2018-02-11 01:24:26 -0600 )edit

The readmes of a lot of pkg on ethz-asl don't explain this, but I guess the authors assume a certain level of knowledge/experience on the part of their users, and don't want to keep duplicating basic install instructions.

gvdhoorn gravatar imagegvdhoorn ( 2018-02-11 01:25:12 -0600 )edit

This is exactly why so many people in the academic community can't be arsed to use ROS - you don't document stuff, when people ask for help you use snide remarks like "basic install instructions" and you assume everyone else has your level of knowledge, like an autistic 10 year old.

Ben12345 gravatar imageBen12345 ( 2018-02-11 06:31:13 -0600 )edit

I've updated my answer and included the dependency on catkin_simple. Anyway there's no need to offend people who share their code and are willing to help fro free. We are a community, not a company ;)

Femer gravatar imageFemer ( 2018-02-11 07:10:56 -0600 )edit
1

@Ben12345: I'm sorry you feel that way. As @Femer writes: we're all just people making their work available to other users, in the hope they might find it useful. We have other things to do, next to that (such as writing papers, running experiments, being scientists).

gvdhoorn gravatar imagegvdhoorn ( 2018-02-11 07:28:56 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-02-10 11:49:50 -0600

Femer gravatar image

updated 2018-02-11 07:09:36 -0600

Ok, let's try like this:

  1. Clone catkin_simple If you don't have it already in your catkin workpsace
  2. Clone in your catkin workspace the catkinized version (from the same author of the ROS interface) of ORB_SLAM2: https://github.com/ethz-asl/orb_slam_2_catkin
  3. Clone the ROS wrapper of the catkinezed version: https://github.com/ethz-asl/orb_slam_2_ros
  4. Compile the ROS wrapper with catkin build orb_slam_2_ros

Action 3 will first try to compile orb_slam_2_catkin, since it's a dependency of orb_slam_2_ros. As you can see in the CMakeLists.txt of orb_slam_2_catkin the original ORB_SLAM2 repository will be cloned and compiled under the hood. So I'm quite sure you don't need to do anything else other than these 3 steps (this means you don't have to follow install instructions in the original ORB_SLAM2 repo by raulmur).

Before proceeding though I'd clean your workspace to make sure you don't have any compilation artefacts from your previous attempt.

Regards,

Marco.

edit flag offensive delete link more

Comments

Thanks! i'll try that tonight. On the off chance i tired to catkin_make https://github.com/ethz-asl/orb_slam_... again and it's at 82% and still going! Not holding my breath for it to work though.

Ben12345 gravatar imageBen12345 ( 2018-02-10 12:11:03 -0600 )edit

Please use catkin build instead of catkin_make ;)

Femer gravatar imageFemer ( 2018-02-10 12:25:04 -0600 )edit
0

answered 2018-12-21 05:09:42 -0600

bart gravatar image

If this may help some future readers, I've made some modifications to ORB-SLAM2 to use the up-to-date version of

  • DBoW2
  • g2o
  • Pangolin

(so, no ThirdParty folder in the repo). It is catkin-ready (both offline apps and online nodes). It requires couples of dependency listed in the repo itself. Here is the repo: srrg_orbslam

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-10 10:01:38 -0600

Seen: 1,180 times

Last updated: Dec 21 '18