I get weird joystick msg

asked 2018-01-29 12:46:13 -0600

chanhyeoni gravatar image

Recently I ran the joystick package, and I got a completely new message as below.

  seq: 229
    secs: 1517251287
    nsecs: 802832704
  frame_id: ''
axes: [-0.0, -0.17600023746490479, -0.0]
buttons: []

Before this, axes was a list of size 10, and buttons a list of size 17. Could it be that the update has been made? Or does it have to do with configuring the Linux interface to the joystick? (I am using the PlayStation 3 and Ubuntu 16.04). I removed and reinstalled the package, but still got the same message.

Also, I tried to change the port from /dev/input/js0 to /dev/input/js1. After rebooting the machine, the port changed back to /dev/input/js0. Any advice on this?

Thank you.

edit retag flag offensive close merge delete



Do you have multiple joysticks (or a hdd with a accelerometer)? What is the output of ls -al /dev/input?

gvdhoorn gravatar image gvdhoorn  ( 2018-01-29 14:22:50 -0600 )edit

i got js0 and js1

chanhyeoni gravatar image chanhyeoni  ( 2018-01-29 15:42:00 -0600 )edit

Do you know what both of those are? I assume one of them is your PS3 joystick, but what is the other?

Try to see if you have a hdd/ssd or some other built-in/embedded accelerometer. That could be enumerated first by the kernel and get js0.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-29 15:42:57 -0600 )edit

I have a similar problem with DualShock2 after upgrading Ubuntu. this is not related to the ROS. at the moment I use https://github.com/chrippa/ds4drv , this complicates things.

0xd1ma gravatar image 0xd1ma  ( 2018-01-30 04:11:02 -0600 )edit

Is there a Debian/Ubuntu bug report you could link to? Any other information? Kernel upgrade?

gvdhoorn gravatar image gvdhoorn  ( 2018-01-30 04:13:06 -0600 )edit

I need to check with my team as to what updates or fixes have been made. In the meantime, I wanted to change the port to /dev/input/js1 using rosparam command (e.g. rosparam set /joy_node/input "/dev/input/js1"). But after reboot, it changed back to js0. Any idea on this?

chanhyeoni gravatar image chanhyeoni  ( 2018-02-02 10:11:27 -0600 )edit