ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

GSCAM Error in ROS

asked 2018-01-28 22:41:19 -0600

pacientes gravatar image

updated 2018-01-28 23:18:41 -0600

jayess gravatar image

Hello everyone.

I have some questions about using gscam in ROS environment and i using NVIDIA Jetson TX2 board, gstreamer-1.0

first, i tried cmd

gst-launch-1.0 v4l2src device="/dev/vodep0" ! "video/x-raw, width=1280, height=800, framerate=30/1 format=(string)UYVY ! nvvidconv flip-method=2 ! "video/x-raw(memory::NVMM), width=1280, height=800, framerate=30/1, format=(string)I420" ! nvegltransform ! nveglglessink

it's very well.

but i tried roslaunch gscam gscam, i have some errors.

path\to\ros\catkin\src\gscam\src\gscam.cpp::167:bool gscam::GSCam::init_stream() assetion failed" (outpad)

so, i had modified v4l.launch file to correct pipeline.

and have too same error.

what can i do for next step?

Thank you advise for me. everyone!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-04 15:21:03 -0600

x029ah gravatar image

You can ask gstreamer to explain an error using GST_DEBUG environment variable:

# GST_DEBUG=4 roslaunch gscam gscam

I'm sure that problem is in incorrect gstreamer pipeline config. Could you post your .launch file here?

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2018-01-28 22:41:19 -0600

Seen: 534 times

Last updated: Feb 04 '18