Ask Your Question
0

Can no longer connect to move_base server

asked 2012-02-19 04:56:04 -0500

Pi Robot gravatar image

updated 2012-02-19 05:31:44 -0500

Hello,

Apologies for this rather vague question, but has something changed with move_base over the past month in the ROS Electric debian version? I have a simple Python script that worked perfectly a month ago and now it hangs on move_base.wait_for_server(). I am running the move_base server and client script on the same machine and I have tried it on two different machines (both running Ubuntu 10.04) with the same problem. My script can be found at: http://code.google.com/p/pi-robot-ros-pkg/source/browse/trunk/experimental/pi_robot/pi_navigation/nodes/nav_test.py.

When running 'rostopic list /move_base' in the terminal where I am running my client script, I see the following nodes:

/move_base/NavfnROS/NavfnROS_costmap/inflated_obstacles
/move_base/NavfnROS/NavfnROS_costmap/obstacles
/move_base/NavfnROS/NavfnROS_costmap/robot_footprint
/move_base/NavfnROS/NavfnROS_costmap/unknown_space
/move_base/NavfnROS/plan
/move_base/TrajectoryPlannerROS/cost_cloud
/move_base/TrajectoryPlannerROS/global_plan
/move_base/TrajectoryPlannerROS/local_plan
/move_base/TrajectoryPlannerROS/parameter_descriptions
/move_base/TrajectoryPlannerROS/parameter_updates
/move_base/current_goal
/move_base/global_costmap/inflated_obstacles
/move_base/global_costmap/obstacles
/move_base/global_costmap/parameter_descriptions
/move_base/global_costmap/parameter_updates
/move_base/global_costmap/robot_footprint
/move_base/global_costmap/unknown_space
/move_base/goal
/move_base/local_costmap/inflated_obstacles
/move_base/local_costmap/obstacles
/move_base/local_costmap/parameter_descriptions
/move_base/local_costmap/parameter_updates
/move_base/local_costmap/robot_footprint
/move_base/local_costmap/unknown_space

Any thoughts how I can debug this?

Thanks!
patrick

edit retag flag offensive close merge delete

Comments

This doesn't really help, but: I am using the same service on lucid and it works for me.

dornhege gravatar imagedornhege ( 2012-02-19 06:04:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-02-19 07:09:42 -0500

Pi Robot gravatar image

OK, I found the problem. For some reason, I had earlier set the update_frequency parameter to 0.0 in my global_costmap_params.yaml file. Apparently this causes the move_base server to not accept client connections. Once I set the update_frequence parameter to 1.0, everything started working again.

P.S. The reason I had set it to 0.0 was that I was trying to block off a room on my map by simply drawing a line across the doorway. However, the robot kept clearing the line when the laser scan passed through that doorway. Someone had suggested turning off the updates on the global costmap so I set the update frequency to 0. Perhaps I only need to set the publish_frequency to 0 to get the desired behavior?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-02-19 04:56:04 -0500

Seen: 325 times

Last updated: Feb 19 '12