Ask Your Question
0

trying to figure out location of interrupt exit -6

asked 2017-11-04 16:28:10 -0500

rnunziata gravatar image

updated 2017-11-06 11:47:15 -0500

I am running a two bag files one runs fine the other produces an error:

[rgbdtam-3] process has died [pid 28773, exit code -6, cmd /home/rjn/catkin_ws/devel/lib/rgbdtam/rgbdtam /camera/rgb/image_color:=/xtion/rgb/image_raw /camera/depth/image:=/xtion/depth/image_raw __name:=rgbdtam __log:=/home/rjn/.ros/log/8047b868-c1a3-11e7-9b8b-0028f87b9f9e/rgbdtam-3.log].
log file: /home/rjn/.ros/log/8047b868-c1a3-11e7-9b8b-0028f87b9f9e/rgbdtam-3*.log

The bag file producing the error has its depth image as 16UC1 and the other bag has 32FC1. I am assuming that is is what is causing the error as there are only image and depth messages in the bag files nothing else.

I tried using dbg to catch the stack trace but it does not produce one.

Does anyone know how to capture the or issue a stack trace form dbg?

thank you.

Here is output of gdb window. note line number reference given....thanks for help.

 V   Thread 15 "rgbdtam" received signal SIGABRT, Aborted.
[Switching to Thread 0x7fffc4b4f700 (LWP 30105)]
0x00007fffed2ff428 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
54      ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) bt
#0  0x00007fffed2ff428 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007fffed30102a in __GI_abort () at abort.c:89
#2  0x00007fffedb5b84d in __gnu_cxx::__verbose_terminate_handler() ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#3  0x00007fffedb596b6 in ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#4  0x00007fffedb59701 in std::terminate() ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#5  0x00007fffedb59919 in __cxa_throw ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#6  0x00007ffff6843cf2 in cv::error(cv::Exception const&) ()
   from /opt/ros/kinetic/lib/libopencv_core3.so.3.2
#7  0x00007ffff6843e83 in cv::error(int, cv::String const&, char const*, char const*, int) () from /opt/ros/kinetic/lib/libopencv_core3.so.3.2
#8  0x00007ffff68e7c9a in cv::_OutputArray::create(int, int, int, int, bool, int) const () from /opt/ros/kinetic/lib/libopencv_core3.so.3.2
#9  0x00007ffff6838eb9 in cv::Mat::copyTo(cv::_OutputArray const&) const ()
   from /opt/ros/kinetic/lib/libopencv_core3.so.3.2
#10 0x000000000047a3c0 in resize_points (points2=..., points=..., 
    reduction=<optimized out>, image_p=..., 
    kinect_initialization=kinect_initialization@entry=1, 
    limit_grad=limit_grad@entry=1)
    at /home/rjn/catkin_ws/src/rgbdtam/src/SemiDenseTracking.cpp:1899
---Type <return> to continue, or q <return> to quit---
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-05 03:02:35 -0500

gvdhoorn gravatar image

Exit code -6 is -SIGABRT (see man/signal(7)).

Does anyone know how to capture the or issue a stack trace form dbg?

Provided you are running rgbdtam inside GDB (using a launch-prefix fi) and rgbdtam is a C++ node, you should just be able to bt <enter> after GDB has caught the crash.

edit flag offensive delete link more

Comments

did that ... but did not produce trace.

rnunziata gravatar image rnunziata  ( 2017-11-06 01:05:07 -0500 )edit

Then I think we're going to need much more information: please show us how you ran the node in GDB exactly (ie: copy-paste from your terminal and / or launch file). More info about the node, any command sequences you used, etc.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-06 01:20:08 -0500 )edit

Additionally (but I've no way of knowing whether you already did that): make sure you've performed a debug build of the package/workspace. Without that, GDB will not be able to find any symbols, making any backtrace much less informative.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-06 01:21:21 -0500 )edit

I ran with launch-prefix="xterm -e gdb --args" in launch file....and compiled with set debug. Got some output in gdb window but but can not seem to copy it ., other wise I would update question. Still not a full stack trace .... as to where in node call is .

rnunziata gravatar image rnunziata  ( 2017-11-06 08:36:01 -0500 )edit

Select the output in the terminal, right mouse button -> copy, or ctrl+shift+c. Then ctrl+v in your question text (edit it), select it, press Preformatted Text button (101010).

gvdhoorn gravatar image gvdhoorn  ( 2017-11-06 08:37:58 -0500 )edit

O wait, you're running in an xterm. Then it's a little different. See ask ubuntu/How does copy-paste work with xterm?.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-06 08:39:18 -0500 )edit

you can copy and past by selecting text in xterm, then simutaiously pressing the left and right enter keys Ive updated the question .. problem resolved.

rnunziata gravatar image rnunziata  ( 2017-11-06 11:43:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-11-04 16:28:10 -0500

Seen: 272 times

Last updated: Nov 06 '17