Ask Your Question
0

The error: cannot resolve host address for machine ....

asked 2017-11-02 15:34:05 -0500

adadada gravatar image

updated 2017-11-07 14:21:02 -0500

gvdhoorn gravatar image

I have installed the ROS in a raspberry 2. I use the code to set the environment .

source environment.sh

After that I make the roslaunch and there is an error code:

roslaunch duckietown joystick.launch veh:=wama

error:

cannot resolve host address for machine [wama]
The traceback for the exception was written to the log file

My URI is wama.local:11311

I changed the hostname to biecuole, and try to ping the biecuole and biecuole.local. They both work but the error is still existing

code:

roslaunch duckietown joystick.launch veh:=biecuole... logging to /home/robot2/.ros/log/f4462c94-c3f7-11e7-b0b6-74da38c7fa07/roslaunch-biecuole-8314.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://biecuole.local:32874/
remote[biecuole.local-0] starting roslaunch
remote[biecuole.local-0]: creating ssh connection to biecuole.local:22, user[zhang]
/usr/lib/python2.7/dist-packages/Crypto/Cipher/blockalgo.py:141: FutureWarning: CTR mode needs counter parameter, not IV
  self._cipher = factory.new(key, *args, **kwargs)
remote[biecuole.local-0]: failed to launch on biecuole:

Unable to establish ssh connection to [zhang@biecuole.local:22]: Server u'biecuole.local' not found in known_hosts

[biecuole.local-0] killing on exit
unable to start remote roslaunch child: biecuole.local-0
The traceback for the exception was written to the log file
edit retag flag offensive close merge delete

Comments

1

Does ping wama in a command terminal work? If not, that is the problem.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-03 00:18:09 -0500 )edit

I changed the hostname to biecuole, and try to ping the biecuole and biecuole.local. They both work but the error is still existing

adadada gravatar image adadada  ( 2017-11-07 14:19:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-11-07 14:26:08 -0500

gvdhoorn gravatar image
Unable to establish ssh connection to [zhang@biecuole.local:22]: Server u'biecuole.local' not found in known_hosts

This error simply tells you that the host you are trying to connect to (using SSH) is not yet known to your own system (ie: the machine from which you are trying to connect to others).

Logging in once with ssh (in a regular terminal session) should solve this (make sure to first check #q41446 though).

edit flag offensive delete link more

Comments

I can ssh the biecuole and biecuole.local Welcome to Ubuntu 16.04.3 LTS (GNU/Linux 4.4.38-v7+ armv7l) * Documentation: https://help.ubuntu.com * Management: https://landscape.canonical.com * Support: https://ubuntu.com/advantage I already used the code in 41446, it does not help

adadada gravatar image adadada  ( 2017-11-07 14:35:10 -0500 )edit

If you ever connected through SSH without adding the option that #q41446 mentions, ssh will not do anything, which could mean that the current entry in known_hosts uses the wrong algorithm.

Just in case, remove any entries for biecuole and biecuole.local and try again.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-08 03:30:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-11-02 15:34:05 -0500

Seen: 1,674 times

Last updated: Nov 07 '17