AttributeError: 'NoneType' object has no attribute 'read'

asked 2017-02-22 10:09:54 -0600

Saif Alabachi gravatar image

I'm trying to run an example from openCv python examples which is I'm using Ubuntu 14.04 ROS Indigo and OpenCV3 with Pyhon 2.7 When I run the example from rosrun like rosrun ucf_ardrone It ran successfully as I want to check that I brought all the required libraries, but when I run it from launch file it show an error.


core service [/rosout] found
process[mosse-1]: started with pid [27040]
GStreamer: Error opening bin: no element "__name"
Traceback (most recent call last):
  File "/home/saif/catkin_ws/src/ucf_ardrone/scripts/", line 198, in <module>
    App(video_src, paused = '--pause' in opts).run()
  File "/home/saif/catkin_ws/src/ucf_ardrone/scripts/", line 150, in __init__
    _, self.frame =
AttributeError: 'NoneType' object has no attribute 'read'
================================================================================REQUIRED process [mosse-1] has died!
process has died [pid 27040, exit code 1, cmd /home/saif/catkin_ws/src/ucf_ardrone/scripts/ __name:=mosse __log:=/home/saif/.ros/log/065b2628-f914-11e6-89bf-3c970e1c0b5b/mosse-1.log].
log file: /home/saif/.ros/log/065b2628-f914-11e6-89bf-3c970e1c0b5b/mosse-1*.log
Initiating shutdown!
[mosse-1] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete

Here is the launch file

    <!-- <node name="hello" pkg="ucf_ardrone" type="" output="screen" required="true" /> -->
    <node name="mosse" pkg="ucf_ardrone" type="" required="true" />

I'm still learning ROS environment so any hint will be great!


edit retag flag offensive close merge delete


How are you running the node from the terminal? Is the node executable?

jayess gravatar image jayess  ( 2017-03-26 02:30:01 -0600 )edit