ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

failed on last step, install ros indigo on raspbian jessie

asked 2017-10-31 09:28:41 -0600

clapfor gravatar image

updated 2017-10-31 11:28:22 -0600

gvdhoorn gravatar image

Direct dump of console output:

/opt/ros/indigo/include/ros/serialization.h:223:5: note: in expansion of macro ‘ROS_CREATE_SIMPLE_SERIALIZER_ARM’
     ROS_CREATE_SIMPLE_SERIALIZER_ARM(double);
     ^
c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions.
CMakeFiles/roscpp.dir/build.make:638: recipe for target 'CMakeFiles/roscpp.dir/src/libros/service_server_link.cpp.o' failed
make[2]: *** [CMakeFiles/roscpp.dir/src/libros/service_server_link.cpp.o] Error 4
CMakeFiles/Makefile2:76: recipe for target 'CMakeFiles/roscpp.dir/all' failed
make[1]: *** [CMakeFiles/roscpp.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
<== Failed to process package 'roscpp':
  Command '['/opt/ros/indigo/env.sh', 'make', '-j4', '-l4']' returned non-zero exit status 2

Reproduce this error by running:
==> cd /home/pi/ros_catkin_ws/build_isolated/roscpp && /opt/ros/indigo/env.sh make -j4 -l4

Command failed, exiting.
edit retag flag offensive close merge delete

Comments

What code are you using? It's really hard to debug your problem if you don't post the code that caused it. Try uploading it to a gist.

bpinaya gravatar image bpinaya  ( 2017-10-31 11:01:36 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-10-31 11:29:14 -0600

gvdhoorn gravatar image
c++: internal compiler error: Killed (program cc1plus)

Most likely your compiler is running out of memory, which makes the OS kill it.

Try to enable some swap for your Pi. That should make it work.

edit flag offensive delete link more

Comments

@gvdhoorn is right. Also try to compile everything with -j2 option instead of default -j4.

l4ncelot gravatar image l4ncelot  ( 2017-11-01 03:02:22 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-10-31 09:27:31 -0600

Seen: 147 times

Last updated: Oct 31 '17