Installing Microsoft Kinect on Ubuntu 16.04 to Use skeletal Tracking

asked 2017-10-20 09:06:45 -0500

Elisabeth gravatar image

Hi Guys, I'm really stuck with getting the Kinect for windows working on my linux laptop running ROS Kinetic with Ubuntu 16.04 LTS. I've downloaded 'freenect2' drivers and got the test stream working from this link fine. However, my aim is to use skeletal tracking. I found a ROS package and installed this as well openni_camera and openni_launch. Whenever I try to run roslaunch openni_launch openni.launch i get an error message saying it cannot find the device 'no device connected' despite the kinect being plugged into the identical usb port as before and powered on. with the command lsusb three Microsoft Corp connections appear and the white light on the adapter of the Kinect is powered up. Whenever I try to run 'rosrun openni_tracker openni_tracker' with roscore it gives Cannot Launch node of this type ! error message. Is this a lost cause on Ubuntu Kinetic?

N.B. I tried downloading the KInectSensor avin2 drivers and installed them with the command. I also installed Nite v1.5 and installed it with the command. None of these make any difference. I also tried openni2_tracker but this brings up the same 'no devices connected!'

Any help would be really appreciated.

edit retag flag offensive close merge delete


I had similar problems when I tried to get my kinect set up. Finally resorted to just running the kinect in Unity3D on a windows machine and using rosbridge to communicate with my ros machine. I had no problems with this method...

mcevoyandy gravatar image mcevoyandy  ( 2017-10-20 10:13:29 -0500 )edit

Try looking at the Linux section here:

jayess gravatar image jayess  ( 2017-10-20 10:17:11 -0500 )edit

Also, this doesn't appear to be ROS-related so you may have more success in getting answers from another site such as Stack Exchange or the like. If you do post a question on another site, please include a link to it here to help others.

jayess gravatar image jayess  ( 2017-10-20 10:19:54 -0500 )edit

it is ROS related as I'm trying to use ROS packages openni_tracker and openni_launch

Elisabeth gravatar image Elisabeth  ( 2017-10-20 10:31:35 -0500 )edit

Right. But, the issue seems to be a hardware issue. Did you try the troubleshooting guide that I posted?

jayess gravatar image jayess  ( 2017-10-20 10:53:23 -0500 )edit