Gmapping Kinect relocating robot

asked 2017-10-20 08:11:11 -0500

Chrizzl gravatar image

My robot has a pretty great odom accuracy, delivered by the robot_pose_ekf package (IMU and odom). When driving around with Rviz as visualization, the robot positioning is correct.

However, when I start creating a map with the gmapping package and the Microsoft Kinect sensor, the position of my robot gets changed slightly, so the Kinect camera can match the new scan with the previous one. Is there some way of disabling this option? I think it might not improve my map at all?

edit retag flag offensive close merge delete