Ask Your Question
0

move_base cpu load

asked 2017-09-29 22:14:03 -0600

tjadhav gravatar image

updated 2017-10-02 20:14:25 -0600

while navigating, move_base goes up to 110% cpu. I'm running turtlebot on the Nvidia Tegra TK1. Other than reducing the map resolution what are some of the other ways to reduce cpu usage on this board ?

Tushar.

Costmap_common

max_obstacle_height: 0.60 # assume something like an arm is mounted on top of the robot

# Obstacle Cost Shaping (http://wiki.ros.org/costmap_2d/hydro/inflation)
robot_radius: 0.14  # org value 0.15, distance a circular robot should be clear of the obstacle (kobuki: 0.18)
# footprint: [[x0, y0], [x1, y1], ... [xn, yn]]  # if the robot is not circular

map_type: voxel

obstacle_layer:
  enabled:              true
  max_obstacle_height:  0.6
  origin_z:             0.0
  z_resolution:         0.2
  z_voxels:             2
  unknown_threshold:    15
  mark_threshold:       0
  combination_method:   1
  track_unknown_space:  true    #true needed for disabling global path planning through unknown space
  obstacle_range: 1.5 #org 2.5
  raytrace_range: 2.0 #org 3.0
  origin_z: 0.0
  z_resolution: 0.2
  z_voxels: 2
  publish_voxel_map: false

obstacle_layer:
  observation_sources: bump laser_scan
  bump: 
    data_type: PointCloud2
    topic: mobile_base/sensors/bumper_pointcloud
    marking: true
    clearing: false
    min_obstacle_height: 0.0
    max_obstacle_height: 0.15
  laser_scan:
    sensor_frame: neato_laser
    data_type: LaserScan
    topic: scan
    marking: true
    clearing: true
    min_obstacle_height: 0.0
    max_obstacle_height: 0.35

# for debugging only, let's you see the entire voxel grid

#cost_scaling_factor and inflation_radius were now moved to the inflation_layer ns
inflation_layer:
  enabled:              true
  cost_scaling_factor:  2.58  # exponential rate at which the obstacle cost drops off (default: 10)
  inflation_radius:     1.75  # org value 0.5 max. distance from an obstacle at which costs are incurred for planning paths.

static_layer:
  enabled:              true

dwa_local_planner

DWAPlannerROS:

# Robot Configuration Parameters - Kobuki
  max_vel_x: 0.14  # org 0.5
  min_vel_x: 0.0 

  max_vel_y: 0.0  # diff drive robot
  min_vel_y: 0.0  # diff drive robot

  max_trans_vel: 0.14 # org value 0.5, choose slightly less than the base's capability
  min_trans_vel: -0.14  # org value 0.1, this is the min trans velocity when there is negligible rotational velocity
  trans_stopped_vel: 0.1

  # Warning!
  #   do not set min_trans_vel to 0.0 otherwise dwa will always think translational velocities
  #   are non-negligible and small in place rotational velocities will be created.

  max_rot_vel: 1.0  # org value 5.0, choose slightly less than the base's capability
  min_rot_vel: -0.10  # org value 0.4, this is the min angular velocity when there is negligible translational velocity
  rot_stopped_vel: 0.4

  acc_lim_x: 1.0 # maximum is theoretically 2.0, but we 
  acc_lim_theta: 2.0
  acc_lim_y: 0.0      # diff drive robot

# Goal Tolerance Parameters
  yaw_goal_tolerance: 0.05  # org value 0.3, 0.05
  xy_goal_tolerance: 0.10  # org value 0.15, 0.10
  # latch_xy_goal_tolerance: false

# Forward Simulation Parameters
  sim_time: 4.0       # org value 1.0, 1.7
  vx_samples: 20       # org value 6,  3
  vy_samples: 1       # diff drive robot, there is only one sample
  vtheta_samples: 40  # org value 20, 20

# Trajectory Scoring Parameters
  path_distance_bias: 32.0      # org value 64.0,  32.0   - weighting for how much it should stick to the global path plan
  goal_distance_bias: 20.0      # org value 24.0, 24.0   - wighting for how much it should attempt to reach its goal
  occdist_scale ...
(more)
edit retag flag offensive close merge delete

Comments

anyone ?

tjadhav gravatar imagetjadhav ( 2017-10-01 10:19:30 -0600 )edit

please, send your costmap configuration files and also your local and global planner config files.

Procópio gravatar imageProcópio ( 2017-10-02 01:55:06 -0600 )edit

away from the Robot computer but will upload them this evening. Thanks Procopio.

tjadhav gravatar imagetjadhav ( 2017-10-02 12:00:57 -0600 )edit

i reduced the map resolution and that lowered the cpu usage to about 80 to 85 % when navigating.

tjadhav gravatar imagetjadhav ( 2017-10-02 21:17:44 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-10-17 08:52:00 -0600

Procópio gravatar image

Sorry for the long delay.

The first thing I'd try is to reduce the # Forward Simulation Parameters. Try reverting to their original values.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-09-29 22:14:03 -0600

Seen: 330 times

Last updated: Oct 17 '17