Ask Your Question
0

find_package error while installing iai_photo

asked 2017-09-29 15:19:37 -0500

vacky11 gravatar image

updated 2017-09-29 15:20:31 -0500

I am trying to install iai_photo package. I have already installed gphoto2 and libgphoto2 libraries and got it working with a sony camera.

Further I git cloned the iai_photo package and tried to catkin_make it. But I get the following error

CMake Error at iai_photo-master/CMakeLists.txt:17 (find_package): By not providing "FindGPHOTO2.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "GPHOTO2", but CMake did not find one.

Could not find a package configuration file provided by "GPHOTO2" with any of the following names:

GPHOTO2Config.cmake
gphoto2-config.cmake

Add the installation prefix of "GPHOTO2" to CMAKE_PREFIX_PATH or set "GPHOTO2_DIR" to a directory containing one of the above files. If "GPHOTO2" provides a separate development package or SDK, be sure it has been installed.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-02 08:11:23 -0500

vacky11 gravatar image

Thanks for your answer. I already found the problem. The error was because of wrong name of package folder

edit flag offensive delete link more
0

answered 2017-10-02 03:42:31 -0500

tfoote gravatar image

It looks like there's an undeclared/documented dependency on an external library gphoto2 that you will need to resolve. I'd suggest ticketing it upstream and asking for feedback on the repository.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-29 15:19:37 -0500

Seen: 80 times

Last updated: Oct 02 '17