Ask Your Question
1

How to modify and build a rosbuild package from source in ros groovy?

asked 2013-06-19 17:55:34 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am trying to modify and build the rosfalcon package. I am using ubuntu 12.04 and groovy.

How do I set up a workspace from an existing package in groovy? There seems to be tons of examples about creating a workspace from scratch, but I couldn't locate any about setting up your environment to modify an already existing package. Everything I tried ended up with either ROS not being able to find that package, or the package not building.

So, if I have the sources for a package I want to modify, where do I place them and which commands should I use to tell ROS it exists/build it/install it?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2013-06-19 19:14:59 -0500

lindzey gravatar image

updated 2013-06-20 08:59:13 -0500

I haven't done this for rosfalcon (and can't find any information about it on the wiki), but this has worked for me:

cd $catkin_ws/src
git clone http://<blah blah blah>
cd $catkin_ws
catkin_make
roscd <package>

Where $catkin_ws is an already existing catkin workspace, whose setup.bash file I've already sourced. I'd guess that you either missed the catkin_make or sourcing the workspace's setup file.

Edit: Thanks for the link! After downloading the code via:

bzr branch http://bazaar.launchpad.net/~cyphylab/cyphy/bonsai

It became clear that the problem is this isn't a catkin-ized package. Check this out for information about using the old-style rosbuild system with catkin. In short, make sure you have the bonsai directory somewhere in your ROS_PACKAGE_PATH, after which you should be able to

rosmake cyphy_rosfalcon

Unfortunately, this gives errors on my system (I'm using OSX), but this should at least solve your build problems.

edit flag offensive delete link more

Comments

Thanks for answering! The rosfalcon package is developped by Queensland UTech, and is located in their bazaar repo, which you can find at tinyurl mvpne3a. I did source the setup file and use catkin_make. It looks like catkin_make doesn't see the package. Anything I can do to fix that?

rsquare gravatar imagersquare ( 2013-06-20 04:09:51 -0500 )edit

I'm sorry - I've never used bzr before ... how do I clone that repo, or whatever the equivalent is? ("bzr branch <url>" didn't work for me - I get "not a branch")

lindzey gravatar imagelindzey ( 2013-06-20 07:16:38 -0500 )edit

(Oh - since you lack the rep to post urls here, feel free to email it to me and I'll post: lindzey[at]gmail)

lindzey gravatar imagelindzey ( 2013-06-20 07:17:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-19 17:55:34 -0500

Seen: 924 times

Last updated: Jun 25 '13