Ask Your Question
1

[SOLVED] How can i install robot_localization?

asked 2017-09-20 04:37:29 -0500

Jair gravatar image

updated 2017-09-21 12:37:08 -0500

Hi,

I tried:

sudo apt-get install ros-kinetic-robot_localization

it installed the package but then when i enter:

roslaunch robot_localization ekf_template.launch

I get this:

error loading <rosparam> tag: 
  file does not exist [/opt/ros/kinetic/share/robot_localization/params/ekf_template.yaml]

so i went to /opt/ros/kinetic/share/robot_localization/ and saw that indeed a bunch of files and folders were missing (im comparing to the git repository -> https://github.com/cra-ros-pkg/robot_... )

i cant download the repository directly into that directory. and theres no build guide for this package. maybe someone here knows what to do? thank you

EDIT:

Ok so i found a workaround. instead of using $ sudo apt-get install ros-kinetic-robot_localization I went into my catkin_ws src folder and opened a terminal. then i entered:

git clone -b kinetic-devel https://github.com/cra-ros-pkg/robot_localization.git

then

cd ~/catkin_ws 
catkin_make

now its installed correctlly with all the files and folders :)

edit retag flag offensive close merge delete

Comments

You should write up your solution as an answer

jayess gravatar image jayess  ( 2017-09-21 12:14:09 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-09-21 11:30:21 -0500

This looks like an oversight in the upstream package. I've filed the following PR:

https://github.com/cra-ros-pkg/robot_...

edit flag offensive delete link more

Comments

Hi i'm new to ROS (and Linux also). may i ask, so what happened here? it wasnt wrong to use "sudo apt-get install" ? using that command should have worked right off the bat?

Jair gravatar image Jair  ( 2017-09-21 11:53:29 -0500 )edit
1

You did everything right. It's just the particular parameter file that that launch file depended on wasn't being installed by the binary version of the package. This is a bug for the package maintainer to fix, but you successfully worked around it by building from source and using the devel space.

mikepurvis gravatar image mikepurvis  ( 2017-09-21 12:04:13 -0500 )edit
1

Thank you very much mikepurvis. I think i'm finally starting to get how ROS works. man the beginning is kinda tough, especially if youre also totally new to linux

very nice community here thanks for the awesome explanation :)

Jair gravatar image Jair  ( 2017-09-21 12:15:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-20 04:37:29 -0500

Seen: 4,018 times

Last updated: Sep 21 '17