Ask Your Question
0

Problem with running json-prolog:prolog to query an owl file

asked 2017-09-07 10:31:17 -0500

aAsoodeh gravatar image

Hi,

I have a cram project running with Ros. i simply want to query an owl file and receive results in cram.

Knowrob is installed on my system and i can run rosrun rosprolog rosprolog knowrob_common examples.


Based on limited documentations and available codes, to query the owl file, i came up with the following code

(json-prolog:prolog '("rdf_has" ?owlname "http://knowrob.org/kb/srdl2-comp.owl#urdfName"("literal")))

i received

; Evaluation aborted on #<SB-KERNEL:CASE-FAILURE expected-type: (OR STRING ROSLISP::URI) datum: NIL>.

i tried every permutation to place owl address, variable and owl command. same error showed up in all cases.

Moreover, by running (json-prolog:check-connection) i have the following error

[(JSON-PROLOG) WARN] 1504631904.665: Node is not running.

I am not sure which node i should run and is it neccessary in order to query the owl file?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-09-07 11:19:18 -0500

gaya gravatar image

updated 2017-09-07 11:24:43 -0500

Hi,

Well, as your warning message suggests, your ROS node is not running. Without a ROS node you cannot do any ROS communication with other nodes. Simply start a new node:

(roslisp:start-ros-node "my_awesome_node")

and try the query again.

I have a suspicion, though, that the ("literal") clause will create problems. For beginners I usually suggest to use the json-prolog:prolog-simple query, which simply accepts a string instead of a list with the query and parameters as json-prolog:prolog does. E.g.:

(json-prolog:prolog-simple "rdf_has(OWLNAME, 'http://knowrob.org/kb/srdl2-comp.owl#urdfName', OTHERVAR).")

Edit: in case you're interested to know what the correct version of your original query is, this is how I would write it:

(json-prolog:prolog '("rdf_has" ?owlname "http://knowrob.org/kb/srdl2-comp.owl#urdfName" ("literal" ?var)))
edit flag offensive delete link more
0

answered 2017-09-11 07:48:32 -0500

aAsoodeh gravatar image

Thanks Gaya,

I tried starting ros node. this is the result:


[(ROSLISP TOP) INFO] 1504894025.528: Node name is /my_awesome_node

[(ROSLISP TOP) INFO] 1504894025.528: Namespace is /

[(ROSLISP TOP) INFO] 1504894025.528: Params are NIL

[(ROSLISP TOP) INFO] 1504894025.528: Remappings are:

[(ROSLISP TOP) INFO] 1504894025.529: master URI is 127.0.0.1:11311

[(ROSLISP TOP) INFO] 1504894026.547: Node startup complete

0


And when i tried check connenction it is still nil but there is no "Node is not running." Any idea?

Thanks

edit flag offensive delete link more

Comments

Well, this looks fine. Your json prolog query still doesn't give the expected results?

gaya gravatar imagegaya ( 2017-09-11 07:55:10 -0500 )edit

No it said ros-rpc call failed with code -1, message no provider, values. [Condition of type ROSLISP::ROS-RPC-ERROR]

aAsoodeh gravatar imageaAsoodeh ( 2017-09-11 08:08:40 -0500 )edit

You need a json_prolog node service provider running. Such that when you do "rosservice list" it shows up in the list (as "json_prolog/query")

gaya gravatar imagegaya ( 2017-09-11 08:27:33 -0500 )edit

Thanks @gaya. right now i have the connection and service. the error that i have this time when i tried prolog-simple example is "Prolog query failed: Got error: The value RDF_HAS is not of type LIST.. [Condition of type SIMPLE-ERROR]" any idea?

aAsoodeh gravatar imageaAsoodeh ( 2017-09-12 09:08:35 -0500 )edit

also i have [(JSON-PROLOG) WARN] 1505226166.532: Service call failed. [(JSON-PROLOG) WARN] 1505226166.532: Retrying...

aAsoodeh gravatar imageaAsoodeh ( 2017-09-12 09:25:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-09-07 10:31:17 -0500

Seen: 79 times

Last updated: Sep 11 '17