ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

does joy support lunar?

asked 2017-09-05 04:13:57 -0500

haichuan gravatar image

updated 2017-09-05 04:54:46 -0500

I try to install ros-lunar-joy on my ubuntu 17.04 os, but i cannot locate the package. Anyone know how to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-09-05 04:28:34 -0500

gvdhoorn gravatar image

updated 2017-09-05 05:06:29 -0500

I try to install ros_lunar_joy

If that is the actual package name that you asked apt-get to install, then that would not work. The debian/ubuntu package name is ros-lunar-joy (note the dashes (-) instead of the underscores (_)).

The following should work:

sudo apt-get install ros-lunar-joy

Edit: this was not immediately clear from the joy wiki page when I checked it, but apparently the joystick_drivers packages have only been released into Lunar 13 days ago (as of 2017-09-05) and are not yet available in the main repository.

See status_page/ros_lunar_default.html?q=joy.

You have a few options:

  1. wait for the next Lunar sync which should include joy (and all other joystick_drivers pkgs)
  2. configure your system to use the shadow repository
  3. build joystick_drivers from source

Option 1 is probably the best - if you can wait.

Option 2 could get you access to the binary packages right now - but be aware of the potential consequences

Option 3 is not recommended, but is an option. Note that just cloning the repository is not enough. See #q252478 for how to build a package from source. But again: don't do this if you don't actually need to.

edit flag offensive delete link more


I already tried this command line, but i cannot locate the package

haichuan gravatar image haichuan  ( 2017-09-05 04:53:31 -0500 )edit

Then we are going to need more information:

  • how did you install ROS (debs? from source?)
  • which architecture is this (amd64, arm)?
  • did you run an apt-get update?

And please provide the complete output of the command. Add it to your original question (use the edit button/link).

gvdhoorn gravatar image gvdhoorn  ( 2017-09-05 04:55:35 -0500 )edit

I use the amd64 and I tried to install from termainal and apt update from termainal, but it still doesnt work.

haichuan gravatar image haichuan  ( 2017-09-05 04:58:48 -0500 )edit

Actually when I try to type ros-lunar-jo and tap, I can only get ros-lunar-joint-

haichuan gravatar image haichuan  ( 2017-09-05 05:01:14 -0500 )edit

See my edit.

gvdhoorn gravatar image gvdhoorn  ( 2017-09-05 05:05:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2017-09-05 04:13:57 -0500

Seen: 127 times

Last updated: Sep 05 '17