Ask Your Question
0

CatkinMake Error in DS325 "depth camera"

asked 2017-08-11 21:07:45 -0500

sasadasd gravatar image

updated 2017-08-12 02:56:33 -0500

gvdhoorn gravatar image

Hello , I try to use DS325 depth camera. To get the following URL' s node, I executed the command "git clone https://github.com/Myzhar/ros_depthse... .

https://github.com/Myzhar/ros_depthse...

Finally , I executed "CatkinMake",but I encountered the following error.

Error message :

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
DEPTHSENSE_LIBRARY
    linked by target "depthsense_camera_node" in directory /home/username/catkin_ws/src/ros_depthsense_camera

-- Configuring incomplete, errors occurred!
See also "/home/username/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/username/catkin_ws/build/CMakeFiles/CMakeError.log".
make: *** [cmake_check_build_system] error 1
Invoking "make cmake_check_build_system" failed

My development environment is Ubuntu14.04 and Indigo.

How should I resolve the error? Please help me.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-08-12 09:31:09 -0500

sasadasd gravatar image

updated 2018-01-27 22:02:20 -0500

jayess gravatar image

Thank you for your reply.

I resolve the problem by executing the following command.

mkdir -p ~/tmp
cd ~/tmp
wget http://files.djduff.net/Download/DepthSense/DepthSenseSDK-1.9.0-5-amd64-deb.run
chmod u+x DepthSenseSDK-1.9.0-5-amd64-deb.run
sudo ./DepthSenseSDK-1.9.0-5-amd64-deb.run # accept agreement

After that I can access the path /opt/softkinetic/DepthSenseSDK.

edit flag offensive delete link more

Comments

I deleted that file which I just put to share for a project - I don't think the creator would be happy with my hosting it. But there are versions of the SDK floating around online still.

DamienJadeDuff gravatar imageDamienJadeDuff ( 2019-08-24 10:29:48 -0500 )edit
1

answered 2017-08-12 02:56:06 -0500

gvdhoorn gravatar image

I would report this over at the issue tracker of that repository.

But in general: just cloning a repository is not enough. You'll have to make sure to have installed all dependencies. In the case of the SoftKinetic cameras, that means installing the DepthSense SDK.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-08-11 21:07:45 -0500

Seen: 170 times

Last updated: Jan 27 '18