permission denied when loading workspace environment on remote machine

asked 2017-08-04 05:10:14 -0600

linusnie gravatar image

I want to run a node on another computer through roslaunch. What I'm doing is:

<machine name="jetson" address="" env-loader="~/el2425_ws/devel/" user="..." password="..."/>
<node machine="jetson" pkg="sensor_helpers" type="" name="imu_processing"/>

But I get the error:

remote[] starting roslaunch
remote[]: creating ssh connection to, user[ubuntu]
/usr/lib/python2.7/dist-packages/Crypto/Cipher/ FutureWarning: CTR mode needs counter parameter, not IV
  self._cipher =, *args, **kwargs)
launching remote roslaunch child with command: [env ROS_MASTER_URI= ~/el2425_ws/devel/ roslaunch -c -u --run_id 071ad98c-1dd4-11b2-b08c-00044b49198a]
remote[]: ssh connection created
remote[]: env: /home/ubuntu/el2425_ws/devel/: Permission denied

How can I give roslaunch permission to to load the environment for the workspace nodes?

edit retag flag offensive close merge delete


According to the logs, it seems that is trying to run a script ~/el2425_ws/devel/

If I'm correct, have you checked if the file have +x permission?

Try chmod +x ~/el2425_ws/devel/

Ruben Alves gravatar image Ruben Alves  ( 2017-08-04 08:29:12 -0600 )edit

@Ruben Alves I tried adding +x permission but the same error still occurs

linusnie gravatar image linusnie  ( 2017-08-08 03:53:16 -0600 )edit

it looks like ssh is missing permission to access the folder

linusnie gravatar image linusnie  ( 2017-08-08 04:00:51 -0600 )edit