permission denied when loading workspace environment on remote machine

asked 2017-08-04 05:10:14 -0600

linusnie gravatar image

I want to run a node on another computer through roslaunch. What I'm doing is:

<machine name="jetson" address="192.168.2.2" env-loader="~/el2425_ws/devel/env.sh" user="..." password="..."/>
<node machine="jetson" pkg="sensor_helpers" type="process_imu.py" name="imu_processing"/>

But I get the error:

remote[192.168.2.2-0] starting roslaunch
remote[192.168.2.2-0]: creating ssh connection to 192.168.2.2:22, user[ubuntu]
/usr/lib/python2.7/dist-packages/Crypto/Cipher/blockalgo.py:141: FutureWarning: CTR mode needs counter parameter, not IV
  self._cipher = factory.new(key, *args, **kwargs)
launching remote roslaunch child with command: [env ROS_MASTER_URI=http://192.168.2.2:11311 ~/el2425_ws/devel/ 
env.sh roslaunch -c 192.168.2.2-0 -u http://192.168.2.210:36330/ --run_id 071ad98c-1dd4-11b2-b08c-00044b49198a]
remote[192.168.2.2-0]: ssh connection created
remote[192.168.2.2-0]: env: /home/ubuntu/el2425_ws/devel/: Permission denied

How can I give roslaunch permission to to load the environment for the workspace nodes?

edit retag flag offensive close merge delete

Comments

According to the logs, it seems that is trying to run a script ~/el2425_ws/devel/env.sh

If I'm correct, have you checked if the env.sh file have +x permission?

Try chmod +x ~/el2425_ws/devel/env.sh

Ruben Alves gravatar imageRuben Alves ( 2017-08-04 08:29:12 -0600 )edit

@Ruben Alves I tried adding +x permission but the same error still occurs

linusnie gravatar imagelinusnie ( 2017-08-08 03:53:16 -0600 )edit

it looks like ssh is missing permission to access the folder

linusnie gravatar imagelinusnie ( 2017-08-08 04:00:51 -0600 )edit