"bash: roscore: command not found" error on Jetson TX2 [closed]

asked 2017-07-30 14:11:18 -0500

cmacks gravatar image

updated 2017-07-31 02:39:20 -0500

130s gravatar image

I just recently installed Ros on my Nvidia Jetson TX2. I am trying to use basic roscore commands but get the error (bash: roscore: command not found) I have run the source /opt/ros/kinetic/setup.bash in this terminal. Still no luck. I used the ROSTX2 install that was made by jetson hacks. Im not sure what i did wrong. Any suggestions?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by gvdhoorn
close date 2017-07-31 14:29:17.485996


This seems like something you should ask the ROSTX2 maintainers / developers. Just to check, do you have the ros-kinetic-roslaunch package installed?

gvdhoorn gravatar image gvdhoorn  ( 2017-07-30 15:16:25 -0500 )edit

oddly enough i gave up yesterday. I just rebooted today and i was able to run roscore meaning the error is gone. I instead get a different error but its not related to this question. So i will post it elsewhere. Thanks though

cmacks gravatar image cmacks  ( 2017-07-31 14:23:52 -0500 )edit

I also ran into problems installing ROS with the ROSTX2 script. After I added the "universe" and "multiverse" repositories to /etc/apt/sources.list the script worked. I had to source setup.bash manually again to run roscore.

Andre Volk gravatar image Andre Volk  ( 2017-07-31 15:04:51 -0500 )edit

@Andre Volk: might be nice to report this to the ROSTX2 maintainers?

gvdhoorn gravatar image gvdhoorn  ( 2017-07-31 15:05:58 -0500 )edit

Sure, I will do that immediately.

Andre Volk gravatar image Andre Volk  ( 2017-07-31 15:28:39 -0500 )edit