Ask Your Question
0

Turtlebot not spawning in Gazebo

asked 2017-07-10 13:49:24 -0500

AndreasG gravatar image

updated 2017-07-12 02:00:24 -0500

gvdhoorn gravatar image

Hi

I just installed ros kinetic, gazebo and turtlebot in Ubuntu 16.04. when i run

roslaunch turtlebot_gazebo turtlebot_world.launch

in terminal gazebo opens with the standard obstacles but there is no bot.

I installed gazebo with apt-get.

this is the error i get i terminal:

[spawn_turtlebot_model-4] process has died [pid 11263, exit code 1, cmd /opt/ros/kinetic/lib/gazebo_ros/spawn_model -unpause -urdf -param robot_description -model mobile_base __name:=spawn_turtlebot_model __log:=/home/andreas/.ros/log/d859e7e6-659c-11e7-bff4-a402b924af68/spawn_turtlebot_model-4.log].
log file: /home/andreas/.ros/log/d859e7e6-659c-11e7-bff4-a402b924af68/spawn_turtlebot_model-4*.log

Any help appreciated!


Edit: This is what terminal is showing when i run roslaunch turtlebot3_gazebo turtlebot3_empty_world.launch.

Still no bot showing:

andreas@andreas-N501VW:~$ roslaunch turtlebot3_gazebo turtlebot3_empty_world.launch 
... logging to /home/andreas/.ros/log/10d4ccd2-6677-11e7-bff4-a402b924af68/roslaunch-andreas-N501VW-30220.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
deprecated: xacro tags should be prepended with 'xacro' xml namespace.
Use the following script to fix incorrect usage:
        find . -iname "*.xacro" | xargs sed -i 's#<\([/]\?\)\(if\|unless\|include\|arg\|property\|macro\|insert_block\)#<\1xacro:\2#g'
when processing file: /opt/ros/kinetic/share/turtlebot3_description/urdf/turtlebot3_burger.urdf.xacro

xacro.py is deprecated; please use xacro instead
started roslaunch server http://andreas-N501VW:35697/

SUMMARY
========

PARAMETERS
 * /robot_description: <?xml version="1....
 * /rosdistro: kinetic
 * /rosversion: 1.12.7
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)
    spawn_urdf (gazebo_ros/spawn_model)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[gazebo-1]: started with pid [30242]
process[gazebo_gui-2]: started with pid [30247]
process[spawn_urdf-3]: started with pid [30252]
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/gazebo_ros/spawn_model", line 32, in <module>
    import tf.transformations as tft
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/tf/__init__.py", line 28, in <module>
    from _tf import *
ImportError: /home/andreas/anaconda2/bin/../lib/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/ros/kinetic/lib/python2.7/dist-packages/tf/_tf.so)
[ INFO] [1499808994.861676790]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1499808994.862201127]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[spawn_urdf-3] process has died [pid 30252, exit code 1, cmd /opt/ros/kinetic/lib/gazebo_ros/spawn_model -urdf -model turtlebot3_burger -x 0.0 -y 0.0 -z 0.0 -param robot_description __name:=spawn_urdf __log:=/home/andreas/.ros/log/10d4ccd2-6677-11e7-bff4-a402b924af68/spawn_urdf-3.log].
log file: /home/andreas/.ros/log/10d4ccd2-6677-11e7-bff4-a402b924af68/spawn_urdf-3*.log
[ INFO] [1499808995.548652766, 0.023000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1499808995.631034578, 0.102000000]: Physics dynamic reconfigure ready.
edit retag flag offensive close merge delete

Comments

Please provide more information on how to reproduce your problem. As well as the full console logs of what you're doing, not just the one line error. http://wiki.ros.org/Support

tfoote gravatar imagetfoote ( 2017-07-10 15:33:29 -0500 )edit

The problem is that i dont find a bot when i run "roslaunch turtlebot_gazebo turtlebot_world.launch" in terminal. Gazebo opens and there are objects like cylinder, jersy barrier, bookshelf an so on showing in the map/world. This happens everytime I run the command. Is it not supposed to show up?

AndreasG gravatar imageAndreasG ( 2017-07-11 15:44:31 -0500 )edit

And where do I find that log?

AndreasG gravatar imageAndreasG ( 2017-07-11 15:45:28 -0500 )edit
1

@AndreasG: please don't pose answers unless you are answering your own question. For everything else, either use comments (to interact with posters of specific answers) or update your original question text. Use the edit button/link for that.

Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2017-07-12 02:01:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-18 16:34:09 -0500

AndreasG gravatar image

I found a solution. There was a problem with having Anaconda2 installed. Since I dont need Anaconda I deleted it along with the content of catkin_ws. I ran the installation steps again and it worked.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-07-10 13:49:24 -0500

Seen: 618 times

Last updated: Jul 18 '17