Ask Your Question
0

Difficulties to takeoff in offboard mode through mavros [closed]

asked 2017-07-03 04:56:35 -0600

Rudja gravatar image

Hello,

I have an issue with the offboard mode on my drone.

I have a pixhawk as flight controller (firmware PX4) and I have installed a raspberry pi 3 as companion computer (Ubuntu Mate 16.04 and ROS Kinetic). Manually, the drone is flying very well. I can go to STABILIZED mode and fly correctly.

When I am using mavros on the rpi to command my drone over wifi and launched my program (rosrun package offb_node), the drone have difficulties to takeoff. It is trying then all motors spin less faster. After the drone landed. I don't think that it is due to the program because it is the offb_node example here ( https://dev.px4.io/en/ros/mavros_offb... ). All is ok with simulation on Gazebo.

The only solution can be a defective motor. Indeed, after the takeoff attempt, the motor 1 is spinning less faster than others. But it is weird because in manual mode, I don't need to compensate.

According to this situation, what do you think is causing that? I will buy another motor if I am sure that it is the problem, but the fact that I have good flying in manual make me hesitate.

Regards,

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2019-05-20 01:42:17.134386

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-28 02:25:47 -0600

Doolly gravatar image

did you solved this issue? I have same problem

edit flag offensive delete link more

Comments

Hi Doolly, I just passed on ROS Indigo.

Rudja gravatar imageRudja ( 2017-11-28 03:13:47 -0600 )edit

@Doolly please don't use answer section for comments.

l4ncelot gravatar imagel4ncelot ( 2017-12-07 07:26:30 -0600 )edit

Question Tools

Stats

Asked: 2017-07-03 04:56:35 -0600

Seen: 558 times

Last updated: Nov 28 '17