Ask Your Question
0

moveit demo.launch, rviz initializing forever

asked 2017-06-28 10:25:39 -0600

stefano gravatar image

updated 2017-06-29 02:51:12 -0600

Hi everyone, here is my problem:

I setup my model using the setup assistant of moveit. Everything seems to work. I export the package, save it under src/ in the catkin_ws/. Then I run "roslaunch my_package demo.launch" .

Here the process starts until the terminal says in green " You can start planning now! " The RViz initializing picture is freezed forever.

However, I get in the terminal "[INFO] [1498661559]: MoveGroup context initialization complete".

What do you think about that? is my PC not strong enough or do I have another problem? Thank you in advance, Stefano

Details:

-I can run RViz stand-alone, no problem.

-I am using a 4 years old laptop, intel i3 quadcore 2.53GHz, geforce 610M.

-I am using Ubuntu 16.04 LTS installed by a friend's usb flashkey

-can I run gazebo if the grafics drivers are not installed?

Complete terminal:

    zampieri@zampieri-Hack:~/catkin_ws$ roslaunch moveit_config_complete_arm_3 demo.launch 
... logging to /home/zampieri/.ros/log/8bbb4536-5bd0-11e7-b431-7ce9d3541a7d/roslaunch-zampieri-Hack-26924.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://zampieri-Hack:45617/

SUMMARY
========

PARAMETERS
 * /joint_state_publisher/use_gui: False
 * /move_group/allow_trajectory_execution: True
 * /move_group/arm/longest_valid_segment_fraction: 0.005
 * /move_group/arm/planner_configs: ['SBLkConfigDefau...
 * /move_group/arm/projection_evaluator: joints(joint_1,jo...
 * /move_group/controller_list: [{'joints': ['joi...
 * /move_group/jiggle_fraction: 0.05
 * /move_group/max_range: 5.0
 * /move_group/max_safe_path_cost: 1
 * /move_group/moveit_controller_manager: moveit_fake_contr...
 * /move_group/moveit_manage_controllers: True
 * /move_group/octomap_resolution: 0.025
 * /move_group/planner_configs/BFMTkConfigDefault/balanced: 0
 * /move_group/planner_configs/BFMTkConfigDefault/cache_cc: 1
 * /move_group/planner_configs/BFMTkConfigDefault/extended_fmt: 1
 * /move_group/planner_configs/BFMTkConfigDefault/heuristics: 1
 * /move_group/planner_configs/BFMTkConfigDefault/nearest_k: 1
 * /move_group/planner_configs/BFMTkConfigDefault/num_samples: 1000
 * /move_group/planner_configs/BFMTkConfigDefault/optimality: 1
 * /move_group/planner_configs/BFMTkConfigDefault/radius_multiplier: 1.0
 * /move_group/planner_configs/BFMTkConfigDefault/type: geometric::BFMT
 * /move_group/planner_configs/BKPIECEkConfigDefault/border_fraction: 0.9
 * /move_group/planner_configs/BKPIECEkConfigDefault/failed_expansion_score_factor: 0.5
 * /move_group/planner_configs/BKPIECEkConfigDefault/min_valid_path_fraction: 0.5
 * /move_group/planner_configs/BKPIECEkConfigDefault/range: 0.0
 * /move_group/planner_configs/BKPIECEkConfigDefault/type: geometric::BKPIECE
 * /move_group/planner_configs/BiESTkConfigDefault/range: 0.0
 * /move_group/planner_configs/BiESTkConfigDefault/type: geometric::BiEST
 * /move_group/planner_configs/BiTRRTkConfigDefault/cost_threshold: 1e300
 * /move_group/planner_configs/BiTRRTkConfigDefault/frountier_node_ratio: 0.1
 * /move_group/planner_configs/BiTRRTkConfigDefault/frountier_threshold: 0.0
 * /move_group/planner_configs/BiTRRTkConfigDefault/init_temperature: 100
 * /move_group/planner_configs/BiTRRTkConfigDefault/range: 0.0
 * /move_group/planner_configs/BiTRRTkConfigDefault/temp_change_factor: 0.1
 * /move_group/planner_configs/BiTRRTkConfigDefault/type: geometric::BiTRRT
 * /move_group/planner_configs/ESTkConfigDefault/goal_bias: 0.05
 * /move_group/planner_configs/ESTkConfigDefault/range: 0.0
 * /move_group/planner_configs/ESTkConfigDefault/type: geometric::EST
 * /move_group/planner_configs/FMTkConfigDefault/cache_cc: 1
 * /move_group/planner_configs/FMTkConfigDefault/extended_fmt: 1
 * /move_group/planner_configs/FMTkConfigDefault/heuristics: 0
 * /move_group/planner_configs/FMTkConfigDefault/nearest_k: 1
 * /move_group/planner_configs/FMTkConfigDefault/num_samples: 1000
 * /move_group/planner_configs/FMTkConfigDefault/radius_multiplier: 1.1
 * /move_group/planner_configs/FMTkConfigDefault/type: geometric::FMT
 * /move_group/planner_configs/KPIECEkConfigDefault/border_fraction: 0.9
 * /move_group/planner_configs/KPIECEkConfigDefault/failed_expansion_score_factor: 0.5
 * /move_group/planner_configs/KPIECEkConfigDefault/goal_bias: 0.05
 * /move_group/planner_configs/KPIECEkConfigDefault/min_valid_path_fraction: 0.5
 * /move_group/planner_configs/KPIECEkConfigDefault/range: 0.0
 * /move_group/planner_configs/KPIECEkConfigDefault/type: geometric::KPIECE
 * /move_group/planner_configs/LBKPIECEkConfigDefault/border_fraction: 0.9
 * /move_group/planner_configs/LBKPIECEkConfigDefault/min_valid_path_fraction: 0.5
 * /move_group/planner_configs/LBKPIECEkConfigDefault/range: 0.0
 * /move_group/planner_configs/LBKPIECEkConfigDefault/type: geometric::LBKPIECE
 * /move_group/planner_configs/LBTRRTkConfigDefault/epsilon: 0.4
 * /move_group/planner_configs/LBTRRTkConfigDefault/goal_bias: 0.05
 * /move_group/planner_configs/LBTRRTkConfigDefault/range: 0.0 ...
(more)
edit retag flag offensive close merge delete

Comments

Can you run RViz stand-alone? What sort of hardware are you using? A regular desktop PC, a raspberry pi, something else? Which Linux version is this, how did you install it, do you have the graphics drivers for your video card installed? Please edit your question and add these details.

gvdhoorn gravatar imagegvdhoorn ( 2017-06-28 10:32:26 -0600 )edit

I made my robot model using the setup assistant as well. The next message I get after the "You can start planning now" is "loading robot model mybot". So maybe there is something wrong with your robot model. Did you write the urdf file yourself? Have you successfully included it in setup assistant?

Felix_N gravatar imageFelix_N ( 2017-06-28 11:54:19 -0600 )edit

@gvdhoorn: Thanks for guiding my question. I updated it.

@felix : Yeah, I dont get "loading robot model mybot". I made the urdf file using the SolidWorks plug-in "export to urdf". I included it successfully in the setup assistant, i can move my joints and see my model. How ever I have some warnings

stefano gravatar imagestefano ( 2017-06-28 12:09:14 -0600 )edit

I corrected the errors in the warnings. I have no more warnings. Still no response from RViz. I hope i don't have to reinstall ros ^^.

stefano gravatar imagestefano ( 2017-06-28 12:25:45 -0600 )edit

can I run gazebo if the grafics drivers are not installed

sometimes. It won't run very well, but it'll probably produce some image.

gvdhoorn gravatar imagegvdhoorn ( 2017-06-28 13:13:49 -0600 )edit

It might help if you copy-paste the complete terminal output into your question (use the Preformatted Text button (the one with 101010 on it)). Can you tell us anything about the model you're trying to load? How big are the meshes? If they are too detailed, loading can be very slow.

gvdhoorn gravatar imagegvdhoorn ( 2017-06-28 13:15:00 -0600 )edit

in the options within the SlidWorks plug-in I could choose corse meshes or fine meshes. I choose fine... How ever I dont get until the "loading robot model mybot" phase (see terminal in the updated question). In addition i left my computer loading for 3-4 hours with no results.

stefano gravatar imagestefano ( 2017-06-28 13:34:18 -0600 )edit

I am going to try anyway with a corse meshing. I keep you updated.

stefano gravatar imagestefano ( 2017-06-28 13:36:27 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-29 16:38:51 -0600

stefano gravatar image

Guys the problem was the nvidia optimus as gvdhoorn said. I switched the driver from "nvidia binary driver" to "Nouveau display driver (open source)". Now it works fine. So the file were not the problem. Thanks again for your help. It makes things really easier. Have a good day <3

edit flag offensive delete link more

Comments

If you have the chance -- and the perseverance -- I would really recommend you try to figure out a way to get optimus to work properly: the nouveau drivers really don't cut it when you start working with any 'real' ROS applications, especially not when you start visualising a lot of data in RViz.

gvdhoorn gravatar imagegvdhoorn ( 2017-06-30 01:38:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-06-28 10:25:39 -0600

Seen: 686 times

Last updated: Jun 29 '17