teb_local_planner tutorial does not show different topologies [closed]

asked 2017-06-21 07:29:58 -0600

littlelordy gravatar image

updated 2017-06-21 07:39:34 -0600

Hi,

I have a question regarding the teb_local_planner tutorial package, more precisely regarding the simulation started with the robot_carlike_in_stage.launch file of the tutorial package. I already made some tests with the test_optim_node beforehand. I then tried to reproduce the scenario of the test_optim_node in its initial state in the stage simulation. That means, I updated the map for the simulation in such a way, that there is an static obstacle just in front of the robot.

Given this situation I would expect the teb_local_planner to plan two trajectories. One on the left of the obstacle and one on the right of the obstacle (like in the test_optim_node). I activated the visualization via the teb_marker in rviz to see the two different trajectories, but it always only shows one trajectory. But when I activate the parameter visualize_hc_graph, I can see, that the planner actually initializes with some trajectories on both sides.

My Parameter configuration equals the default configuration of the tutorial_package: https://github.com/rst-tu-dortmund/te...

Can anybody give me a hint what I am doing/understanding wrong?

Thank you in advance for your help, Greetings, Frank

EDIT: I made a video to clearify my question: https://www.youtube.com/watch?v=E-NKi...

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by littlelordy
close date 2017-07-03 08:33:12.755089

Comments

@croesmann maybe you could give me a helping hand with this?

littlelordy gravatar image littlelordy  ( 2017-06-22 03:51:09 -0600 )edit

I found the error. It's quite embarrassing, but I just had an outdated version of the package, which I installed from source a few month ago. When I installed the new version everything works fine now.

littlelordy gravatar image littlelordy  ( 2017-07-03 08:36:12 -0600 )edit