Ask Your Question
1

RViz Motion Planning Error: Failed to load motion planning plugin library

asked 2017-06-09 14:47:23 -0600

Tesla gravatar image

updated 2017-06-09 16:06:19 -0600

I was running a Moveit tutorial on Motion Planning (ROS Indigo version) when I got the error,

MotionPlanning
The class required for this display, 'moveit_rviz_plugin/MotionPlanning', could not be loaded.
Error:
Failed to load library /opt/ros/indigo/lib/libmoveit_motion_planning_rviz_plugin.so. Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = libopencv_imgproc.so.2.4: cannot open shared object file: No such file or directory)

The first time when I launched the tutorial, I got a similar error and fixed it by

sudo apt-get update
sudo apt-get dist-upgrade

as suggested in Rviz motion_planning Error: Failed to load library, but has not worked since.

I have installed opencv3.2.0, is that the reason why this isn't working? Or is the opencv plugin a part of ROS? I checked the library files in Moveit and this is the output:-

>> ls /opt/ros/indigo/lib | grep open
libgazebo_ros_openni_kinect.so
libopenni2_camera_nodelet.so
libopenni2_driver_lib.so
libopenni2_wrapper.so
openni2_camera

>> ls /opt/ros/indigo/lib | grep motion
libmoveit_motion_planning_rviz_plugin_core.so
libmoveit_motion_planning_rviz_plugin_core.so.0.7.3
libmoveit_motion_planning_rviz_plugin.so
libmoveit_motion_planning_rviz_plugin.so.0.7.3
libstdr_ideal_motion_controller.so
libstdr_omni_motion_controller.so

>> ls /usr/local/lib | grep libopencv_imgproc.so
libopencv_imgproc.so
libopencv_imgproc.so.3.2
libopencv_imgproc.so.3.2.0

Is there a way to make RViz use the 3.2 version instead?

Any help would be appreciated. Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-09 17:42:01 -0600

ahendrix gravatar image

It looks like the plugin is compiled against packages that use OpenCV 2.4, and can't be used with a different version. You may be able to recompile the moveit rviz plugin with the updated version of OpenCV

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-06-09 14:47:23 -0600

Seen: 1,527 times

Last updated: Jun 09 '17