Ask Your Question
0

rosrun tf2_tools not found

asked 2017-06-06 14:34:37 -0600

achille gravatar image

In the very first tutorial of tf2, we run the command rosrun tf2_tools view_frames.py. I tried this on two different systems running Ubuntu 16.04 and ROS kinetic. On both systems, I get the error [rospack] Error: package 'tf2_tools' not found. I built my workspace using catkin_make and sourced my workspace. the ros master is running and I followed all tutorials exactly. rospack find tf2_tools yields the same error, but tf2 itself can be found. Any ideas why this is failing?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-06 17:56:25 -0600

tfoote gravatar image

You probably need to install tf2_tools if rospack can't find it.

sudo apt-get install ros-$ROS_DISTRO-tf2-tools

If that's the issue we should add that as a dependency of tf2_turtle.

edit flag offensive delete link more

Comments

That worked. I was using an underscore in ros-$ROS_DISTRO-tf2-tools (tf2_tools). It should probably be a dependency indeed.

achille gravatar imageachille ( 2017-06-06 19:50:48 -0600 )edit

Glad that worked. I decided instead to just add it to the tutorial since the package itself doesn't need it really.

tfoote gravatar imagetfoote ( 2017-06-06 20:05:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-06-06 14:34:37 -0600

Seen: 590 times

Last updated: Jun 06 '17