rqt_plot shows up, but doesn't plot any data?

asked 2017-05-31 09:56:41 -0600

thanhvu94 gravatar image

I'm using Arduino to send 6 output analog signals through rosserial_arduino with a rostopic named /sensor_msg1. The custom message type I use has only one component is int16[6] led1.

I want to observe the change of the signal through rqt_plot, but when I run on the commandline rqt_plot /sensor_msg1, the rqt_plot GUI shows up but no data is plotted. There are only a legend mentioning 6 elements of led1 messages. In the commandline, there is a warning also: "libEGL warning: DRI2: failed to authenticate".

When I run rostopic list:

pi@pi-desktop:~/catkin_ws$ rostopic list
/diagnostics
/rosout
/rosout_agg
/sensor_msg1

It is weird that when I use rostopic echo, the data is published, or when I tried to do rqt_plot for turtlesim tutorial in ROS website, rqt_plot can plot the position of the turtle anyway.

Can anyone tell me what is the problem and how to fix it?

Thank you.

edit retag flag offensive close merge delete

Comments

will rqt correctly plot any of the sensor_msg1 indices? I.e. does running rqt_plot /sensor_msg1[0] produce what you would expect?

maxsvetlik gravatar imagemaxsvetlik ( 2017-05-31 11:39:00 -0600 )edit

As I said, when I run rqt_plot /sensor_msg1/led1[0] instead, the GUI shows up but no line or data is plotted. I don't know if the warning is the reason for this problem?

thanhvu94 gravatar imagethanhvu94 ( 2017-05-31 11:53:04 -0600 )edit

I assume you've already checked trouble shooting section of wiki. You may want to share the full output of rostopic echo for the topic you want to plot. And a .bag file helps even more if that's possible.

130s gravatar image130s ( 2017-05-31 14:04:43 -0600 )edit