ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

ROS Lunar version conflict with Ubuntu 16.04LTS - libcollida-dom2

asked 2017-05-30 00:29:00 -0600

John Nagle gravatar image

updated 2017-05-30 00:29:56 -0600

As with each new ROS release, there are install conflicts. The system on which the install was done was running Ubuntu 16.04LTS, updated with the latest Ubuntu updates before ROS install was attempted. Previous versions of ROS had been removed.

During ROS install, Ubuntu reported a system problem:

Package: libcollida-dom2.4-do0 2.4.4+ds1-1.
collida-dom

"An Ubuntu package has a file conflict with a package that is not a genuine Ubuntu package".

At the end of the ROS install, that install reported.

Errors were encountered while processing:
 /var/cache/apt/archives/libcollada-dom2.4-dp0_2.4.4+ds1-1_amd64.deb
 /var/cache/apt/archives/libcollada-dom2.4-dp-dev_2.4.4+ds1-1_amd64.deb

This looks a lot like the problem reported here, in 2015:

http://answers.ros.org/question/22289...

But that bug was in ROS-Indigo for Ubuntu 14.04. It was fixed there. Looks like it's been broken again.

edit retag flag offensive close merge delete

Comments

If I then run Ubuntu's software updater, it wants to update Collida-dom to 2.4.0. So the ROS and Ubuntu updaters are now fighting.

John Nagle gravatar image John Nagle  ( 2017-05-30 00:38:37 -0600 )edit

See also https://github.com/ros/robot_model/is... where this was fixed in 2015. Now it's broken again.

John Nagle gravatar image John Nagle  ( 2017-05-31 11:59:49 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-31 15:35:20 -0600

John Nagle gravatar image
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-05-30 00:29:00 -0600

Seen: 210 times

Last updated: May 30 '17