Ask Your Question
0

ResourceNotFound: xarco

asked 2017-05-18 12:19:21 -0500

dshimano gravatar image

updated 2017-05-18 12:20:22 -0500

Hi, I am trying to write a launch file for a URDF. When I run rosrun xacro xacro workcell.xarco the ,xarco runs no problem, but when I run my .launch file I get

ResourceNotFound: xarco
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/donni/ROS_ws/ind_ws/src
ROS path [2]=/opt/ros/kinetic/share

Also, when I run rospack find xarco, ros doese not find xarco. How is ros able to run xarco using rosrun, but can't find it with rospack. Also, how do I add xarco to my ros environment?

Thank you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-05-18 12:51:51 -0500

gvdhoorn gravatar image

You have the r and the c in the wrong order.

It's xacro, not xarco.

And the xacro package is almost certainly part of the default ROS install, so you should already have it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-18 12:19:21 -0500

Seen: 992 times

Last updated: May 18 '17