Unable to visualize tutorial urdf robots in rviz

asked 2017-05-14 12:34:04 -0500

surob gravatar image

updated 2017-05-17 04:35:45 -0500

I'm in /opt/ros/lunar/share/urdf_tutorial and when i run:

roslaunch urdf_tutorial display.launch model:=urdf/05-visual.urdf

only TF and gripper elements are visible: https://i.imgur.com/a/8OQqz.gif

For all other tutorial robots only TF is visible. I tried setting LIBGL_ALWAYS_SOFTWARE=1 but it didnt help.

All rviz, launch, urdf files are unmodified lunar versions.

If you have any ideas why is this happening please let me know, thanks!

edit retag flag offensive close merge delete

Comments

It's not horribly helpful, but I ran this myself on Lunar and saw all of the elements. Is this a Lunar only problem? What OS are you running?

David Lu gravatar image David Lu  ( 2017-05-18 16:19:33 -0500 )edit

Hi, thanks for reply. Im on Ubuntu 17.04 zesty and it's kinda hard to check this under other ros versions because lunar is the only one avaible for zesty.

surob gravatar image surob  ( 2017-05-21 12:59:26 -0500 )edit

I ran it in a virtualbox instance of 17.04/lunar and it worked. Make sure you are running the latest version of Rviz and try again? This seems like an rviz problem more than a urdf_tutorial problem.

David Lu gravatar image David Lu  ( 2017-05-22 11:37:39 -0500 )edit

This could be caused by locale settings. See ros-visualization/rviz#1151.

gvdhoorn gravatar image gvdhoorn  ( 2017-11-20 09:25:48 -0500 )edit