catkin_create_android_project unsupported command create project

asked 2017-05-11 18:43:11 -0500

tkkhuu gravatar image

I followed the tutorial at: to create a new android project. But it seems like the current SDK does not support the "android create project" command anymore. Does anyone have a suggestion to fix this?

The error is:

tkkhuu@TK-UBUNTU:~/myandroid/src/android_foo$ catkin_create_android_project -t 10 -p bar

Creating android project Name : bar Target Ver: 10 Java Name : Activity : Bar

Command: ['android', 'create', 'project', '-n', 'bar', '-p', '/home/tkkhuu/myandroid/src/android_foo/bar', '-k', '', '-t', 'android-10', '-a', 'Bar']

The "android" command is deprecated. For manual SDK, AVD, and project management, please use Android Studio. For command-line tools, use tools/bin/sdkmanager and tools/bin/avdmanager

Invalid or unsupported command "create project -n bar -p /home/tkkhuu/myandroid/src/android_foo/bar -k -t android-10 -a Bar"

Supported commands are: android list target android list avd android list device android create avd android move avd android delete avd android list sdk android update sdk Error [error] __init__() takes at least 3 arguments (2 given) : <type 'exceptions.typeerror'="">

edit retag flag offensive close merge delete


@hulkbv I have not been able to, I haven't worked on it for a while, have you been able to figure it out?

tkkhuu gravatar image tkkhuu  ( 2017-07-05 20:48:22 -0500 )edit

hey @tkkhuu, you need to switch back to the SDK tools old version, version 25.2.5 or lower would be ok. Have fun!

hulkbv gravatar image hulkbv  ( 2017-07-06 03:43:01 -0500 )edit

@hulkbv Oh I see, is it simply uninstalling newer SDKs on android studio and install older SDK versions such as 25.2.5? Is there anything we need to configure in ROS?

tkkhuu gravatar image tkkhuu  ( 2017-07-08 11:12:49 -0500 )edit

Okay I was able to fix it, I simply delete the tools folder in Sdk and downloaded an older version of SDK tools. Thanks a lot man.

tkkhuu gravatar image tkkhuu  ( 2017-07-09 11:58:03 -0500 )edit