Ask Your Question
4

catkin_create_android_project throws error

asked 2015-06-03 11:45:19 -0500

Tones gravatar image

I tried to create a custom ROS-Android package as described in the tutorial Creating Android Packages. Unfortunately, the command catkin_create_android_project -t 10 -p com.github.ros_java.android_foo.bar bar fails with this error:

[error] [Errno 2] No such file or directory : <type 'exceptions.OSError'>

Can anyone help me with this problem? My current workaround is to copy an existing example project.

ROS distro: Indigo; rosjava_core version: 0.2.1 (installed from debs); rosjava_build_tools version: 0.2.3 (installed from debs); android_core version: 0.2.0 (compiled from source)

edit retag flag offensive close merge delete

Comments

Did you find any more permanent sollution to this?

smihael gravatar imagesmihael ( 2015-08-16 04:26:44 -0500 )edit

Unfortunately not, so far. I am still using the workaround.

Tones gravatar imageTones ( 2015-08-19 10:28:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-03-15 09:50:12 -0500

JellyLD gravatar image

This is because catkin_create_android_project actually calls android create project to create a ros_android project, you see the no such file error because catkin_create_android_project can not find the android script, what you need to do is add a PATH env varible.

If you use Linux and bash, you need to add something to the .bashrc like this: PATH="WHAT_IS_ALREADY_THERE:YOUR_ANDROID_SCRIPT_PATH" and then source .bashrc in terminal.

Normally, the android script is at YOUR_SDK_ROOT/tools.

edit flag offensive delete link more

Comments

Thank you! This worked for me!

ErivaldoJunior gravatar imageErivaldoJunior ( 2016-08-10 10:19:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-06-03 11:45:19 -0500

Seen: 1,125 times

Last updated: Mar 15 '16