Missing tfs from turtlebot2 in gazebo

asked 2017-05-05 11:51:40 -0500

sterlingm gravatar image

updated 2017-05-09 10:45:35 -0500

Hi,

When I run the turtlebot_world.launch file in turtlebot_gazebo, there are many missing transformations compared to when I run minimal.launch on a real turtlebot. This is the result I get from rosrun tf view_frames:

image description

I have not been able to figure out why these are the only transforms available. When I run minimal.launch on a real robot, there are many more, such as transforms for camera_depth and camera_rgb, cliff sensors, etc. Are the transforms shown above the only transforms expected when running turtlebot_world.launch?

When I look at the /robot_description param after running turtle_world.launch, it looks to be the same value as when I run minimal.launch. It's very long, but here is the first part:

"<?xml version=\"1.0\" ?>\n<!-- ===================================================================================\
  \ -->\n<!-- |    This document was autogenerated by xacro from /opt/ros/kinetic/share/turtlebot_description/robots/kobuki_hexagons_asus_xtion_pro.urdf.xacro\
  \ | -->\n<!-- |    EDITING THIS FILE BY HAND IS NOT RECOMMENDED                \
  \                 | -->\n<!-- ===================================================================================\
  \ -->\n<!--\n    - Base      : kobuki\n    - Stacks    : hexagons\n    - 3d Sensor\
  \ : kinect\n-->\n<robot name=\"turtlebot\" xmlns:xacro=\"http://ros.org/wiki/xacro\"\

On the real robot's laptop, I am using Hydro. On my desktop that is running the gazebo simulator, I am using Kinetic.

Please let me know if this is the behavior and/or how to get the rest of the Turtlebot2 transforms. Thanks for any help.

edit retag flag offensive close merge delete

Comments

I was not able to figure this out, but here is a link to a small node to publish the missing tfs for the Turtlebot2 camera: https://github.com/sterlingm/ramp/blo...

sterlingm gravatar imagesterlingm ( 2017-05-09 10:44:54 -0500 )edit